Last modified: 2006-01-12 10:57:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 4571 - Transclusion of {{fullurl:{{FULLPAGENAME}}}} on Commons gives broken links elsewhere
Transclusion of {{fullurl:{{FULLPAGENAME}}}} on Commons gives broken links el...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.6.x
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Image:Du...
:
: 4544 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-12 09:23 UTC by bdk
Modified: 2006-01-12 10:57 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description bdk 2006-01-12 09:23:07 UTC
There are several pages on Commons that are used as templates 
for user specific license boxes, compare (permalink to current version):
http://commons.wikimedia.org/w/index.php?title=User:Raymond_de/licence&oldid=1171429

The variables {{fullurl:{{FULLPAGENAME}}}} are used correctly there 
and work well while viewing images directly on Commons. 

But if you look at a transcluded image elsewhere, e.g.
http://en.wikipedia.org/wiki/Image:Duisburg-Ruhrort_Panorama_1.jpg
you'll find (below the license) a broken link at the template section 
"Onlinemedium". This link is in the form of 
http://commons.wikimedia.orghttp://commons.wikimedia.org/wiki/Image:Duisburg-Ruhrort_Panorama_1.jpg
(fullurl is doubled).
Comment 1 Brion Vibber 2006-01-12 09:28:27 UTC
What do they 'work' to do? URLs aren't template names...
Comment 2 Brion Vibber 2006-01-12 09:47:09 UTC
Simpler test case:
http://test.leuksman.com/index.php?action=render&title=4571

This is probably because the hack for URL expansion in render mode is misplaced in 
Title::getLocalUrl() instead of higher up where it belongs. Something is then applying a 
duplicate $wgServer on the front.
Comment 3 Brion Vibber 2006-01-12 10:10:43 UTC
Fixed on HEAD; Title.php revision 1.258.

Just a quick-fix hack; avoid duplicating the prefix in getFullUrl() if the test for 
render in getLocalUrl() passes and already prepends it.
Comment 4 Raimond Spekking 2006-01-12 10:57:55 UTC
*** Bug 4544 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links