Last modified: 2007-05-08 11:13:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 4378 - Render external protocols defined in $wgUrlProtocols in the same manner
Render external protocols defined in $wgUrlProtocols in the same manner
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://ar.wikipedia.org/wiki/image:Mo...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-24 10:59 UTC by lɛʁi לערי ריינהארט
Modified: 2007-05-08 11:13 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description lɛʁi לערי ריינהארט 2005-12-24 10:59:18 UTC
Hallo!

*specific task*
Please note that you are not able to click on the external link under the image
at http://ar.wikipedia.org/wiki/image:Mozart_2.jpg using Firefox.

[[wikipedia:ar:]] is displaying external links as "plainlinks". This has no
influence on the rendering of the external link at the url from above.

I assume that this class attribute (?) is not set properly for pages in the
{{ns:image}} namespace. (Sorry for this wording but CSS is new for me.)

*general bug pattern*
Please take a look at similar parts in the MediaWiki code (including extensions)
where the CSS atributes for external links are not set properly / in the same
manner as done for rendering of pages in the main namespace.


The first issue was addressed already at bug 4295 comment 25. It relates to a
Firefox bug.

(from bug 4295 comment #27)

> In order to start I reported the particular you mentioned at:
> https://bugzilla.mozilla.org/show_bug.cgi?id=179393#c11 and #12
> == [Bug Bugzilla 179393] - images between two input fields are displayed in the
> wrong order
> This was a wrong place.
> 
> see
> https://bugzilla.mozilla.org/attachment.cgi?id=206193 for
> https://bugzilla.mozilla.org/show_bug.cgi?id=178991#c17
> == [Bug  Bugzilla 178991] BiDi: Unclickable links if near neutral characters
> e.g. parentheses, bullets


Using class (attribute) "external link" (?) everywhere would offer a workaround
(the usage of "plainlinks") for about 30 Wikimedia foundation projects using one
of the 11 RTL languages: [[ar:]], [[arc:]], [[dv:]], [[fa:]], [[he:]], [[ks:]],
[[ps:]], [[sd:]], [[ug:]], [[ur:]], [[yi:]]. This is wy the priority is set to
"major".

Thanks for your help in advance!

best regards reinhardt [[user:gangleri]]
Comment 1 Antoine "hashar" Musso (WMF) 2007-05-08 11:13:25 UTC
The image is part of the wiki so it is not really external
and does not deserve an 'external' class.

It works as intended.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links