Last modified: 2010-05-15 15:38:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 4065 - Installation problem ("InnoDB"?)
Installation problem ("InnoDB"?)
Status: CLOSED INVALID
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.5.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 19:58 UTC by Sonic Chan
Modified: 2010-05-15 15:38 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sonic Chan 2005-11-24 19:58:38 UTC
I am using a "fresh" MySQL 5.0.  I am stuck during installation.  Please help me
if you can.


Checking environment...

    * PHP 5.0.5: ok
    * PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title)
    * Have XML / Latin1-UTF-8 conversion support.
    * PHP is configured with no memory_limit.
    * Have zlib support; enabling output compression.
    * Neither Turck MMCache nor eAccelerator are installed, can't use object
caching functions
    * GNU diff3 not found.
    * Couldn't find GD library or ImageMagick; image thumbnailing disabled.
    * Installation directory: C:\NetServ\Root\wiki
    * Script URI path: /wiki
    * Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider
changing it manually.
    * Trying to connect to MySQL on localhost as root...
          o Connected as root (automatic)
    * Connected to 5.0.15-nt; enabling MySQL 4 enhancements
    * Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider
changing it manually.
    * Created database wikidb
    * Creating tables...Query "CREATE TABLE PP_user ( user_id int(5) unsigned
NOT NULL auto_increment, user_name varchar(255) binary NOT NULL default '',
user_real_name varchar(255) binary NOT NULL default '', user_password tinyblob
NOT NULL default '', user_newpassword tinyblob NOT NULL default '', user_email
tinytext NOT NULL default '', user_options blob NOT NULL default '',
user_touched char(14) binary NOT NULL default '', user_token char(32) binary NOT
NULL default '', user_email_authenticated CHAR(14) BINARY, user_email_token
CHAR(32) BINARY, user_email_token_expires CHAR(14) BINARY, PRIMARY KEY user_id
(user_id), UNIQUE INDEX user_name (user_name), INDEX (user_email_token) )
TYPE=InnoDB" failed with error code "The 'InnoDB' feature is disabled; you need
MySQL built with 'InnoDB' to have it working".
Comment 1 Brion Vibber 2005-11-24 20:39:04 UTC
Fix your MySQL installation, it's broken.
Comment 2 Rob Church 2005-11-24 20:57:37 UTC
Take the opportunity to upgrade to version 1.5.2 as well.
Comment 3 Sonic Chan 2005-11-24 21:30:59 UTC
I have finally solved the problem.  Thanks for your help!

When I was still trying version 1.5.0, it reports VARIOUS error messages when I
tried many different settings in MySQL 5.0.
But when I switched to version 1.5.2, it works.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links