Last modified: 2005-12-03 12:00:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 4031 - not able to clear "You have new messages" when making a redirect from your talk page to another talk page
not able to clear "You have new messages" when making a redirect from your ta...
Status: RESOLVED DUPLICATE of bug 3805
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Low trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-19 15:14 UTC by lɛʁi לערי ריינהארט
Modified: 2005-12-03 12:00 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description lɛʁi לערי ריינהארט 2005-11-19 15:14:02 UTC
Sorry for this.

If you have an account for your bot and you make a redirect from
user_talk:FooBot to
user_talk:Foo
and somebody posts messages at user_talk:FooBot then you would not be able to
"clear" the "You have new messages" for the user:FooBot acount.

This bug might be platform dependend as I do not know how MediaWiki gets
confused by the cookies for the different accounts.

regards reinhardt [[user:gangleri]]

P.S. Please confirm the bug.
Comment 1 T. Gries 2005-11-19 17:02:35 UTC
The flag is usually cleared when you visited the orignal (non-redirected) page
Comment 2 lɛʁi לערי ריינהארט 2005-11-19 18:12:45 UTC
(In reply to comment #1)
> The flag is usually cleared when you visited the orignal (non-redirected) page


I know. It happens to me at
http://test.leuksman.com/view/Special:Recentchanges
when I am logged in as
http://test.leuksman.com/index.php?title=User:%D7%90_%D7%91_%D7%92_%D7%93&redirect=no
This happens with
*Netscape*
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20051012
Netscape/8.0.4
Build number: 20051012
and
*Firefox*
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Firefox/1.0.7
also when clearing the cach with CTRL-SHIFT-R
Comment 3 Rob Church 2005-11-20 00:24:03 UTC
So what is the problem?
Comment 4 lɛʁi לערי ריינהארט 2005-11-20 07:13:41 UTC
You need to create two accounts at FiverAlpha User:Foo and User:FooBar.

Then use another browser - you should log in anonymosly *or* as User:Foo and
make a redirect from User_talk:FooBar to User_talk:Foo.

If you go to the browser where you are logged in as User:FooBar you can see the
problem: You can *not* get read of the "You have new messages".
Comment 5 Rob Church 2005-11-20 14:58:47 UTC
I meant, had the problem been worked around? Can you not manually go to the
redirect page with &redirect=no?
Comment 6 lɛʁi לערי ריינהארט 2005-11-20 15:13:13 UTC
I cleared the redirect at
http://test.leuksman.com/history/User_talk:%D7%90_%D7%91_%D7%92_%D7%93

However the problem is still there - I pressed CTRL-SHIFT-R In Netscape.
It might be that
a) does not handle the cash correctly ( I still get "You have new messages") at
http://test.leuksman.com/view/Special:Recentchanges
b) something else is broken at FiverAlpha
Comment 7 lɛʁi לערי ריינהארט 2005-12-03 12:00:37 UTC

*** This bug has been marked as a duplicate of 3805 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links