Last modified: 2004-09-19 06:29:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39 - Monobook fails WinXP (Favicon.ico not found)
Monobook fails WinXP (Favicon.ico not found)
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-14 06:45 UTC by Timwi
Modified: 2004-09-19 06:29 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Timwi 2004-08-14 06:45:13 UTC
BUG MIGRATED FROM SOURCEFORGE
http://sourceforge.net/tracker/index.php?func=detail&aid=990830&group_id=34373&atid=411192
Originally submitted by Matt Edel (matted)  2004-07-14 14:33


ver 1.3. monobook on winxP/apache php 4.3.4

In all browsers, the tabs render ok, but nothing else
does. The layout is completely broken. Earlier versions
worked fine.

Symptoms: 
>> Main Page starting flush left in the quickbar
region. (see attached screen shot

>>Font reads as Times on WinXP platform, and
Arial/sans-serif  on my live linux host.

>> when I orginally tried the install script, it
failed. Each click on "Setup your Wiki" link simply
added the /config dir to the address path.  I then
accessed config/index.php directly and it was fine. 
Could something have been fubared by this? Not likely. 

The ONLY Apache error is :
[error] [client 127.0.0.1] File does not exist:
C:/htdocs/favicon.ico

Favicon.ico is in the images directory.  Why is it
being sought in my server root?

Is this a clue? 

Install was vanilla. Globals are registered in php.ini

Localsettings.php all looks normal

Help!  Unusable this way.   I see no similar reports
anywhere, and yet my setup is pretty generic so I'm
assuming there's a bug somewhere.

.

------------------------- Additional comments ------------------------
Date: 2004-07-14 14:48
Sender: SF user matted

The faveicon is a typical windows funny, I am told. So
forget that part :)
-------------------------------------------------
Date: 2004-07-21 00:33
Sender: SF user imsop

Sounds to me like at least part of your problem is your
*apache* config - the clue being that it didn't find the
/index.php by itself. That's a fairly cosmetic setting (you
have to add "index.php" on the end of the "DirectoryIndex"
line) but there may be others tripping you up more
seriously. Have you got anything else [fairly complex]
working successfully on this server?

It's not immediately obvious what could be wrong, but things
like Apache reporting the wrong "Content-type:" for CSS
files might be able to have catastrophic effects like this.
It's a pretty odd and major bug otherwise, isn't it!?
-------------------------------------------------
Date: 2004-07-21 05:13
Sender: SF user matted

Thank for responding. I was losing hope. We are doing all
our development on our live server, and that's awkward. I'd
like to have my winXP machine running mediawiki. 

My Apache confiq is this thisaway... so I presume that isn't
the problem.  
DirectoryIndex index.html index.html.var index.php

This is so bizarre. At first I thought that the style sheets
weren't being referenced.. but they are. But most of the
rules are being clobbered... but only in monobook (the only
style we are using).  Standard and CologneBlue run just
fine. Any other ideas? I am just completely befuddled. I
love this product, and we are coding up a storm with it, but
I need to get it to run on my local machine. 

Can you please tell me where most of the active developers
can be found for forward looking issues? Are the email lists
the only option, or are their active forums somewhere?





-------------------------------------------------
Date: 2004-07-21 13:39
Sender: SF user imsop

That is indeed thoroughly bizarre. Have you tried things
like reading the Apache *access* log after making a request,
to see if the browser asked for all the things you would
expect it to need and making some fake GET requests (using
libwww-perl or something) to see if there's anything funny
about the responses? Not that I can think what you'd be
looking for, but...

Also, there's not some way that something firewall-ish could
be limiting the flow of data/number of connections from the
webserver is there?

As for how to get in touch, there is indeed a live channel:
#mediawiki on irc.freenode.net; there's also the mailing
lists, which it sounds like you found already, the most
relevant to you being
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l

Good luck!
-------------------------------------------------
Date: 2004-07-21 14:24
Sender: SF user matted

Yes.. the log is clean. Virtually no errors reported, even
after clean restarts. 

I am totally mystified. Maybe I can ask the list. 

Is MediaWikia-L  only a list?  Does it share messages with
the wikipedia.technical news group?  (or is it its own
group? If so, I can't find it on the gmane server. Does it
have another name there?

Thanks again for your help. If you havr ANY new thoughts,
please let me know. I am running out of hope--but for you!
-------------------------------------------------
Date: 2004-08-02 08:42
Sender: SF user vibber

Sounds like you're missing the stylesheets directory or have
hidden it
with broken rewrite rules or have not updated it or something.

Can you confirm that it is correctly installed and that files
there are
accessible and that the HTML output references the correct URLs?

-------------------------------------------------
Date: 2004-08-08 07:53
Sender: SF user vibber

Can the original reporter please check with a fresh install of
beta6 and
confirm that the problem is either still present or not?
Comment 1 JeLuF 2004-09-19 06:29:58 UTC
Closed. Outdated. Can't be solved without feedback from original poster.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links