Last modified: 2012-06-21 13:49:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3841 - Fails on user.php
Fails on user.php
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.5.x
PC Linux
: High blocker (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.meta-showdown.de/wiki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-30 23:13 UTC by Benjamin Marwell
Modified: 2012-06-21 13:49 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Benjamin Marwell 2005-10-30 23:13:25 UTC
When installing after manual (copying new files, deleting old LocalSettings.php
and tried to run setup) this happened:

Checking environment...

    * PHP 4.3.4: ok
    * Warning: PHP's register_globals option is enabled. MediaWiki will work
correctly, but this setting increases your exposure to potential security
vulnerabilities in PHP-based software running on your server. You should disable
it if you are able.
    * PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title)
    * Have XML / Latin1-UTF-8 conversion support.
    * PHP's memory_limit is 32M. If this is too low, installation may fail!
    * Have zlib support; enabling output compression.
    * Neither Turck MMCache nor eAccelerator are installed, can't use object
caching functions
    * GNU diff3 not found.
    * Found GD graphics library built-in, image thumbnailing will be enabled if
you enable uploads.
    * Installation directory: /home/httpd/vhosts/meta-showdown.de/httpdocs/wiki
    * Script URI path: /wiki
    * Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider
changing it manually.

      Notice: Undefined variable: wgUseTurckShm in
/home/httpd/vhosts/meta-showdown.de/httpdocs/wiki/includes/Setup.php on line 158

      Fatal error: Call to a member function on a non-object in
/home/httpd/vhosts/meta-showdown.de/httpdocs/wiki/includes/User.php on line 320

----

Funny... line #320 in user.php is EMPTY. Can't go on. Tried to update from
1.4.7. No custom changes made to wiki.
Comment 1 Brion Vibber 2005-10-31 08:29:15 UTC
It sounds like you may have a mix of files from different versions. Please confirm 
that you have the correct files.
Comment 2 Benjamin Marwell 2005-10-31 13:45:50 UTC
Well yes and now. The manual did wrong when it says "overwrite existing files
with new ones". Instead you have to delete more files than just the
LocalSettings.php and that admin file.

Just a mistake in the manual... After deleting and uploading everything but the
images it started working again.
Comment 3 Marcin Cieślak 2012-06-21 13:49:55 UTC
*** Bug 31893 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links