Last modified: 2006-06-04 00:21:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3830 - subst: does not substitute parameters with default arguments
subst: does not substitute parameters with default arguments
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Templates (Other open bugs)
unspecified
All other
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Wikipedi...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-29 23:19 UTC by squell
Modified: 2006-06-04 00:21 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description squell 2005-10-29 23:19:06 UTC
If a template contains, say {{{Param|default}}}, and if the subst'ed template
did not have a 'Param' parameter, subst:template will insert
"{{{Param|default}}}" in the wikimarkup instead of "default" as I'd expected.
This isn't a problem (currently), but it looks pretty silly. And I doubt this
feature was intentional.

The other problem described on the url is already in another PR.
Comment 1 Brion Vibber 2006-06-04 00:21:59 UTC
This seems to have been fixed some time in the last 
months.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links