Last modified: 2010-05-15 15:38:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3805 - Phantom 'You have new messages' notification with enotif
Phantom 'You have new messages' notification with enotif
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.5.x
All All
: Normal normal with 6 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 4031 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 21:52 UTC by Muke Tever
Modified: 2010-05-15 15:38 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Quick fix for REL1_5 (1017 bytes, patch)
2005-12-09 23:24 UTC, Brion Vibber
Details

Description Muke Tever 2005-10-26 21:52:20 UTC
Since upgrading to 1.5.0 (and still now at 1.5.1) a 
user has experienced the "You have new messages" 
notification at all times, even though he has 
visited his talk page, and it has not been edited.

On a separate wiki I have experienced the same 
problem, creating a new user account and editing my 
own talk page: I get "You have new messages" on 
every page except the talk page itself; even upon 
updating / editing the talk page, it doesn't go 
away.
Comment 1 Rob Church 2005-10-26 22:47:40 UTC
Is this a caching problem? Try a refresh or a hard-refresh from within your
browser. Also, check the talk page history to make sure it *hasn't* been edited.
Comment 2 Filip Maljkovic [Dungodung] 2005-10-26 22:54:02 UTC
This is an odd behavior that was present in 1.5rcX (and/or 1.5betaX) too. There
is a page on meta describing how to get rid of this, but in my case I've tried
everything, except messing with DB. Some other users have reported the same thing.
Comment 3 Muke Tever 2005-10-26 23:05:29 UTC
Yes, it's no caching problem (at least, no browser-caching 
problem) as it still shows up even visiting new pages, and the 
talk page hasn't been edited.

Filip: Could you link to that meta page?  I'm not finding it.
Comment 4 Filip Maljkovic [Dungodung] 2005-10-27 11:08:56 UTC
Muke: I can't seem to find it either. Maybe it wasn't meta. Possibly another bug...
Comment 5 Ben Arnold 2005-10-30 21:12:46 UTC
I have had this problem on 1.5b4 and 1.5.1. In our case it happens every time a user talk page is modified. 
The only way we can clear the "you have new messages" notification is to watch-cycle the talk page.

As other people have reported, the "you have new messages" notification appears after the talk page has been 
visited even on new pages that I haven't visited before, so it's clearly not a browser caching issue. (And 
hard-refreshing the browser doesn't help.)

MediaWiki: 1.5.1 
PHP: 4.3.8 (apache2handler) 
MySQL: 4.0.20a-debug 
Comment 6 T. Gries 2005-10-31 00:30:49 UTC
The revisited Enotif patch 
  http://bugzilla.wikimedia.org/show_bug.cgi?id=2014 

and also the current version of EnotifWiki based on MediaWiki1.5rc4 see  
  http://developer.berlios.de/projects/enotifwiki/ and http://www.enotifwiki.org

do not show this problem. Unfortunately, currently I cannot supply a "diff"
patch for MW 1.5.1 
Comment 7 Jeremy Butler 2005-12-02 19:40:17 UTC
I can confirm that this bug persists in

MediaWiki: 1.5.2
PHP: 4.3.2 (apache2filter)
MySQL: 3.23.58
Redhat Linux

Comment 8 stux 2005-12-03 07:52:21 UTC
We have noticed at the HRWiki that the bug seems to affect only those usernames
that contain spaces on them. 
Comment 9 lɛʁi לערי ריינהארט 2005-12-03 12:00:32 UTC
(In reply to comment #8)
> ... seems to affect only those usernames that contain spaces on them.

This is the case refered in
Bug 4031: not able to clear "You have new messages" when making a redirect from
your talk page to another talk page

best regards reinhardt [[user:gangleri]]
Comment 10 lɛʁi לערי ריינהארט 2005-12-03 12:00:38 UTC
*** Bug 4031 has been marked as a duplicate of this bug. ***
Comment 11 Tom Preuss 2005-12-03 17:51:25 UTC
(In reply to comment #8)
> We have noticed at the HRWiki

Details for our setup:

* MediaWiki: 1.5.2
* PHP: 4.3.11 (apache)
* MySQL: 4.0.25-standard 
* Linux 2.4.21-4.ELsmp
Comment 12 Ben Arnold 2005-12-04 21:07:31 UTC
We are using "Firstname Lastname" for our usernames, so they all contain the 
space character. WikiSysop is the only user on our system without a space in 
their name. When I logged in as WikiSysop and viewed its talk page the 
banner message was cleared. So I can confirm that on our installation having 
a space in the username appears to be a precondition for the bug to occur. 

I have tried again unsuccessfully to reproduce the bug at Wikipedia. 
Discussion on Mediawiki-l suggested that the special caching software used 
at Wikimedia sites might hide the bug.

My setup is described above, running on Windows XP Professional.
Comment 13 Ben Arnold 2005-12-05 02:39:38 UTC
I have tried ticking the "Disable page caching" option under user preferences, but this doesn't fix the problem.
Comment 14 Rob Church 2005-12-05 07:29:22 UTC
(In reply to comment #12)
> I have tried again unsuccessfully to reproduce the bug at Wikipedia. 
> Discussion on Mediawiki-l suggested that the special caching software used 
> at Wikimedia sites might hide the bug.

Unless the bug or whatever is fixed in 1.6-dev, in which case it won't affect
Wikipedia, nor any other Wikimedia web site, since we live on the edge with
those. ;-)
Comment 15 T. Gries 2005-12-05 07:56:30 UTC
(In reply to comment #0)
> user has experienced the "You have new messages" 
> notification at all times, even though he has 
> visited his talk page, and it has not been edited.... 
> updating / editing the talk page, it doesn't go 
> away.

Perhaps you can contact the user and ask to click once onto the "Mark all pages
visited" link on their watchlist (to see if the problem is then solved).

Already some week ago, I recommended also to apply my patch as mentioned in
comment 6 to this bugzilla http://bugzilla.wikimedia.org/show_bug.cgi?id=3805#c6 .
Comment 16 lɛʁi לערי ריינהארט 2005-12-05 11:49:55 UTC
(In reply to comment #14)
> (In reply to comment #12)
> > I have tried again unsuccessfully to reproduce the bug at Wikipedia.

Rob please tray to reproduce the bug at http://test.leuksman.com/ creating a new
account containing spaces. Please let us know the results. Thanks in advance!
Comment 17 lɛʁi לערי ריינהארט 2005-12-05 11:51:46 UTC
Ups wrong link!

(In reply to comment #14)
> > I have tried again unsuccessfully to reproduce the bug at Wikipedia.

Rob please tray to reproduce the bug at http://test.leuksman.com/view/Main_Page
creating a new
account containing spaces. Please let us know the results. Thanks in advance!
Comment 18 lɛʁi לערי ריינהארט 2005-12-08 23:58:34 UTC
changing to WORKSFORME
I tested this extensivly with various usernames ( see
http://test.leuksman.com/view/Category:Bugzilla/BiDi )containing a space at
http://test.leuksman.com/ .

The problem disapeared. Thanks Brion!
Comment 19 Tom Preuss 2005-12-09 00:25:48 UTC
(In reply to comment #18)
> changing to WORKSFORME
> I tested this extensivly with various usernames ( see
> http://test.leuksman.com/view/Category:Bugzilla/BiDi )containing a space at
> http://test.leuksman.com/ .
> 
> The problem disapeared. Thanks Brion!

But this bug relates to behavior in version 1.5.  http://test.leuksman.com runs
version 1.6devel.

I might be wrong in doing this, and please correct me if I'm wrong, but I'm
removing the WORKSFORME tag and reopening, as it does not work on version 1.5.
Comment 20 Ben Arnold 2005-12-09 00:43:38 UTC
I agree it appears to be fixed at leuksman.com. What version is that site at? Can 
we assume it will also be fixed in the next stable release?

Maybe it's already fixed in 1.5.3. Has anyone upgraded to 1.5.3 and checked this 
defect?

Sorry about the barrage of questions!
Comment 21 Ben White 2005-12-09 01:03:17 UTC
The bug persists in 1.5.3.  Our configuration:

MediaWiki: 1.5.3 
PHP: 4.3.11 (apache) 
MySQL: 4.0.25-standard
Comment 22 Brion Vibber 2005-12-09 23:23:10 UTC
This is a bug in the old enotif code, which has since been replaced on the development branch.
Comment 23 Brion Vibber 2005-12-09 23:24:18 UTC
Created attachment 1167 [details]
Quick fix for REL1_5

Fixed bad comparison in UserTalkUpdate.php
Comment 24 Ben White 2005-12-15 21:39:11 UTC
I applied the above patch, and it resolved the problem at our wiki. Thanks, Brion!
Comment 25 Brion Vibber 2005-12-18 06:45:56 UTC
Must have forgot to mark this FIXED.
Comment 26 Ben Arnold 2005-12-18 21:18:21 UTC
Thanks heaps for the patch Brion, it works perfectly for me too.
Comment 27 Ben Arnold 2005-12-22 03:30:25 UTC
I can confirm that this is in 1.5.4. Thanks!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links