Last modified: 2013-02-25 17:15:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3738 - MySQL 5.0 issues (tracking)
MySQL 5.0 issues (tracking)
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
unspecified
All All
: Low normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
: tracking
Depends on: 1322 3735 3786 6737 7669 15851
Blocks: tracking
  Show dependency treegraph
 
Reported: 2005-10-18 18:23 UTC by Brion Vibber
Modified: 2013-02-25 17:15 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2005-10-18 18:23:04 UTC
Track issues with MySQL 5.0, charset/collation work etc on this bug.
Comment 1 Andreas Neuhaus 2005-10-23 17:41:22 UTC
I'm using mediawiki-1.5.0 with MySQL 4.1.14, which is set to use UTF8 as the
default charset. However, because most other old web apps here use Latin1, the
default connection charset is set to Latin1 (in my.cnf: init-connect = 'set
names latin1'). I.e. the MySQL server keeps everything in UTF8, but talks Latin1
by default to the clients. Because mediawiki is fully capable of using UTF8, it
can/should talk UTF8 directly with the database, so I changed
includes/Database.php to tell MySQL that mediawiki wants to talk UTF8:

--- mediawiki-1.5.0/includes/Database.php       2005-08-28 23:59:17.000000000 +0200
+++ wiki/includes/Database.php  2005-10-23 19:06:24.000000000 +0200
@@ -223,6 +223,7 @@
                                # may cause some operations to fail possibly.
                                @/**/$this->mConn = mysql_connect( $server,
$user, $password );
                        }
+                       $this->query('SET NAMES utf8');
                }

                if ( $dbName != '' ) {

This works fine, but should probably have an additional check like: if
mysql_version >= 4.1 then send "set names utf8".

mediawiki-1.5.0 was also able to display everything correctly while talking
Latin1 with our database, but I suppose in that case mediawiki did the
translation from latin1 to utf8 (because pages were displayed in utf8). I
suppose, letting the database to the translation scales better than changing
encodings in PHP. Also there was a minor glitch with pages that have german
umlauts in their name. The page links were displayed in red (not existing), even
if they existed. And if you click the link, the edit page came up and the
textbox was filled with the content of the existing page.
Comment 2 Brion Vibber 2005-10-23 21:02:17 UTC
Please do not place specific comments on this bug, this is a tracking bug. File new 
bugs, and list this bug as dependent on it.
Comment 3 Andrew Garrett 2009-07-29 16:38:49 UTC
Adding 'tracking' keyword.
Comment 4 Andre Klapper 2013-02-25 17:15:32 UTC
No open dependencies left and 5.0 was released in 2005 => closing as FIXED.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links