Last modified: 2012-04-24 01:57:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 36 - Fuzzy title search doesn't match substrings of titles
Fuzzy title search doesn't match substrings of titles
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-14 06:44 UTC by Timwi
Modified: 2012-04-24 01:57 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Timwi 2004-08-14 06:44:53 UTC
BUG MIGRATED FROM SOURCEFORGE
http://sourceforge.net/tracker/index.php?func=detail&aid=994574&group_id=34373&atid=411192
Originally submitted by Matt Kaufman (kaufman_matt)  2004-07-20 17:23


We have been using MediaWiki 1.3 on MySQL 3.x 
for about two weeks now and have noticed some 
strange search behavior with the search button.  

We have a two pages:
	"Migrating Old Code"
	"Migration"

When performing a search for "Migrating", the 
results are:
	Search results
	For query "migrating"
	No page with this exact title exists, trying 
full text search.
	Migration 77% (****) 

Nothing else is returned.  It says nothing about 
the "Migrating Old Code" page.  At first I thought 
there was an issue with MediaWiki not searching 
page titles, so I tried a few tests and it worked 
fine.  I also tried putting the word "Migrating" in 
the text of other pages to see if the search results 
(shown above) would change.  They did not...

-Matt

------------------------- Additional comments ------------------------
Date: 2004-08-05 08:44
Sender: SF user vibber

Is this still going on? Is this a public wiki we can poke at?
-------------------------------------------------
Date: 2004-08-06 17:30
Sender: SF user kaufman_matt

Sorry, it is not a public wiki.  It's still happenig even 
after upgrading to MySQL 4.
-------------------------------------------------
Date: 2004-08-10 21:38
Sender: SF user vibber

(Adjusting categorization of bug.)
Comment 1 Wil Mahan 2004-09-17 17:43:20 UTC
This only happens when $wgDisableFuzzySearch = false. Here's the problem:

We do a fuzzy title search on the word "Migrating". That takes all titles of
approximately the same length as "migrating", and returns all titles within a
certain Levenshtein distance of the word. Thus the "Migration" article shows up,
but since "Migrating Old Code" isn't about the same length as "migrating", it
isn't even considered.

I think we could either WONTFIX this bug, or modify the fuzzy title search to
also use another way of matching titles.
Comment 2 Brion Vibber 2004-09-21 20:24:32 UTC
Fuzzy title search is sufficiently problematic that I think we should just disable it by 
default.

It was originally intended to be a middle step between the exact title match ('go') 
and the much slower fulltext search on the title field; however we had more 
performance problems with it on Wikipedia and disabled it there. On a more general 
server it tends to return unexpected results and doesn't make it obvious how to do a 
normal search after that.
Comment 3 Brion Vibber 2004-10-28 02:30:02 UTC
Fuzzy search is being removed in 1.4.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links