Last modified: 2005-06-21 13:39:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 35 - Incorrect behavior of =={{:template}}==
Incorrect behavior of =={{:template}}==
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Antoine "hashar" Musso (WMF)
: need-parsertest, parser
Depends on: 152
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-14 06:44 UTC by Timwi
Modified: 2005-06-21 13:39 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Timwi 2004-08-14 06:44:46 UTC
BUG MIGRATED FROM SOURCEFORGE
http://sourceforge.net/tracker/index.php?func=detail&aid=994833&group_id=34373&atid=411192
Originally submitted by Nobody/Anonymous - nobody  2004-07-20 23:41


Attempting to place an escaped template in a section
name produces HTML similar to the following:

<p><a name="&lt;a href=" class="new"
title="template">template</a>"&gt;</p>

[[en:User:Eequor]]
Comment 1 Antoine "hashar" Musso (WMF) 2004-08-16 16:02:22 UTC
Looking at it. There is some other cases that need fixing :


== {{exist}} ==
== {{:exist}} ==
{{:exist}}

all 3 output a non existent link to [[Exist]]


== {{:doesntexist}} ==
{{:doesntexist}}

both output a non existent link to [[Exist]] instead of [[Template:Exist]]


The toc entries are empty unless one use {{template:exist}}
Comment 2 Antoine "hashar" Musso (WMF) 2004-08-16 20:31:34 UTC
I think I triggered the bug. See bug #152 for detail / progress.
Comment 3 Antoine "hashar" Musso (WMF) 2004-08-16 20:42:24 UTC
Ignore my previous comment. I misunderstood the way {{}} works.

Back to first comment:
I haven't found any trouble with that in the current cvs HEAD.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links