Last modified: 2010-05-15 14:36:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3386 - Recent Changes feeds (RSS/Atom) at Vietnamese-language sites have extra, invalid line at top
Recent Changes feeds (RSS/Atom) at Vietnamese-language sites have extra, inva...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://vi.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-07 18:52 UTC by Minh Nguyễn
Modified: 2010-05-15 14:36 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Minh Nguyễn 2005-09-07 18:52:42 UTC
The RSS and Atom Recent Changes feeds at the Vietnamese Wikipedia, Wiktionary,
Wikibooks, and Wikiquote all have an extra, blank line at the top. Mozilla-based
browsers, as well as Mozilla Thunderbird, choke on this line, since it is
apparently invalid XML. In Firefox:


XML Parsing Error: xml declaration not at start of external entity
Location:
http://vi.wikipedia.org/w/index.php?title=%C4%90%E1%BA%B7c_bi%E1%BB%87t:Recentchanges&feed=rss
Line Number 2, Column 1:
<?xml version="1.0" encoding="utf-8"?>
^


In Thunderbird:


http://vi.wikipedia.org/w/index.php?title=%C4%90%E1%BA%B7c_bi%E1%BB%87t:Recentchanges&feed=rss
is not a valid RSS feed.


This issue has cropped up since the installation of the new Vietnamese language
pack for MediaWiki. See Bug #2143.
Comment 1 Ævar Arnfjörð Bjarmason 2005-09-07 19:13:07 UTC
An extre newline at the end of LanguageVi.php appears to have been the issue,
closing as FIXED.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links