Last modified: 2004-11-12 14:17:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 334 - Newtalk flag sometimes not cleared from cache
Newtalk flag sometimes not cleared from cache
Status: RESOLVED DUPLICATE of bug 26
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 03:23 UTC by Timwi
Modified: 2004-11-12 14:17 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Timwi 2004-09-03 03:23:18 UTC
BUG MIGRATED FROM SOURCEFORGE
http://sourceforge.net/tracker/index.php?func=detail&aid=843038&group_id=34373&atid=411192
Originally submitted by Nobody/Anonymous - nobody  2003-11-16 07:29


I get the "you have new messages" link when I've
already seen them, under mozilla 1.5.  Clearing my
cache does not help, nor does hitting reload, or
setting the cache to compare on each view, so it almost
has to be a server problem.  

Thanks!  

user:Pakaran

username "nrussell" AT domain "buffalo dot edu".

------------------------- Additional comments ------------------------
Date: 2003-11-16 09:04
Sender: SF user vibber

This is a known problem; the root cause is not yet certain, but
the
immediate cause is that the user data stored in the cache is 
sometimes not cleared when the notification marker is cleared
in
the database. The wiki continues to use the cached data, which 
now incorrectly lists a new messages notification flag; the flag
doesn't subsequently get recleared because you see the cached 
copy of your talk page and it doesn't get to the part where it
clears
the flag.

Workarounds:
* really force a page reload on your user talk page (ctrl+ or
shift+
reload should work in IE/Mozilla)
* watch/unwatch any page
* log out, log back in
* edit your talk page
Comment 1 Zigger 2004-10-30 16:06:47 UTC
Just happened for me on http://en.wikipedia.org/wiki/Category:People while
browsing anonymously, but the messages were for a different IP address which is
20 hops away.

Possibly relevant bits from the bad page source:
  "<div class="usermessage">You have <a href="/wiki/User_talk:195.93.32.13"
title ="User talk:195.93.32.13">new messages</a>.</div>"
  "This page was last modified 01:27, 25 Oct 2004."
  "Served by vincent.wikimedia.org in 1.47 secs."

From the later reloaded page source:
  "This page was last modified 01:27, 25 Oct 2004."
  "Served by bart.wikimedia.org in 1.18 secs."
Comment 3 Antoine "hashar" Musso (WMF) 2004-11-12 14:17:42 UTC
duplicate of #26 which is solved.

*** This bug has been marked as a duplicate of 26 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links