Last modified: 2010-05-15 15:37:49 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3204 - Special namespace translation for fy: broken
Special namespace translation for fy: broken
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.5.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 00:25 UTC by Daniel Herding
Modified: 2010-05-15 15:37 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Daniel Herding 2005-08-20 00:25:38 UTC
Hi,

according to phase3/languages/LanguageFy.php rev. 1.61 the Special namespace for
the Frysk Wikipedia, Wiktionary etc. is called 'wiki'. But when I open
http://fy.wikipedia.org/wiki/wiki:Recentchanges , it will send me to page
[[Recentchanges]] in namespace 0, which of course doesn't exist. This behaviour
has obviously been changed recently, it worked fine some days ago.

We stumbled over this because the PyWikipediaBot tried to load Special pages
using 'Wiki' as the namespace. The bot software has now been updated to use the
English default namespace name.

But it's still a problem because there are now some broken links within the
Frysk Wikipedia, e.g.
http://fy.wikipedia.org/w/index.php?title=Recent_Changes&action=edit , and some
from the outside, e.g. the fy: interwiki link on
http://de.wikipedia.org/wiki/Spezial:Recentchanges and probably many links on
the Web.

Daniel
Comment 1 Brion Vibber 2005-08-20 02:08:39 UTC
A mass update of language files introduced a typo, "MS_SPECIAL", which breaks 
functioning:
http://cvs.sourceforge.net/viewcvs.py/wikipedia/phase3/languages/
LanguageFy.php?r1=1.54.8.1&r2=1.54.8.2

This has been corrected.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links