Last modified: 2011-03-09 21:14:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3135 - Special:Allmessages broken in 1.5b4 after upgrade
Special:Allmessages broken in 1.5b4 after upgrade
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.5.x
PC Linux
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://gentoo-wiki.com/Special:Allmes...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 20:41 UTC by Mike Valstar
Modified: 2011-03-09 21:14 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mike Valstar 2005-08-13 20:41:01 UTC
I recently upgraded to 1.5b4 on my site and it is having problems with:
Special:Allmessages , see link 

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in
/var/www/gentoo-wiki.com/htdocs/includes/SpecialAllmessages.php on line 31

Warning: ksort() expects parameter 1 to be array, null given in
/var/www/gentoo-wiki.com/htdocs/includes/SpecialAllmessages.php on line 32

Warning: Invalid argument supplied for foreach() in
/var/www/gentoo-wiki.com/htdocs/includes/SpecialAllmessages.php on line 36

Thank you for your time
Comment 1 Antoine "hashar" Musso (WMF) 2005-08-13 20:59:17 UTC
From special:version:
* MediaWiki: 1.5beta4
* PHP: 5.0.4 (apache2handler)
* MySQL: 4.0.22 
Comment 2 Brion Vibber 2005-08-13 22:33:25 UTC
As I recall this was the fix:
http://cvs.defau.lt/cvsweb.cgi/phase3/includes/MessageCache.php.diff?
r1=1.59&r2=1.60

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links