Last modified: 2010-05-15 15:37:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3008 - $wgWhitelistRead doesn't work with special characters
$wgWhitelistRead doesn't work with special characters
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.5.x
PC All
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 02:48 UTC by Jan Eglinger
Modified: 2010-05-15 15:37 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jan Eglinger 2005-08-02 02:48:46 UTC
I've installed MediaWiki 1.5beta4 on PHP 4.3.10 (cgi).

Setting the reading permissions through $wgWhitelistRead in LocalSettings.php
seems not to accept special characters:

not working:
"My_Namespace:Page", "My Namespace:Über uns", "My Namespace:%C3%9Cber uns"

working:
"My Namespace:Page", "My Namespace:Uber uns"

How do I have to encode special characters in $wgWhitelistRead in order to get
this working?
Comment 1 Brion Vibber 2005-08-02 09:43:27 UTC
You need to save the file in UTF-8 encoding.

(Be sure not to include a BOM character on the file, which some buggy editors will add by default. This 
can cause failures in some HTTP or XML output modes.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links