Last modified: 2010-05-15 15:33:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 296 - Message variables substituted at install time
Message variables substituted at install time
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.4.x
All All
: High normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 315 2260 (view as bug list)
Depends on:
Blocks: 202
  Show dependency treegraph
 
Reported: 2004-09-03 03:08 UTC by Timwi
Modified: 2010-05-15 15:33 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Timwi 2004-09-03 03:08:56 UTC
BUG MIGRATED FROM SOURCEFORGE
http://sourceforge.net/tracker/index.php?func=detail&aid=948139&group_id=34373&atid=411192
Originally submitted by Sean Proctor (sproctor)<a href="/help/icon_legend.php?context=user_wantsdonations&amp;user_id=43755&amp;return_to=%2F"><IMG src="http://images.sourceforge.net/images/icons/donate.png" alt="Accepting Donations" border="0" width="16" height="16"></a>  2004-05-05 03:26


My wiki is behind a proxy server. I have $wgServer set
properly. the rest of the links follow that, but the
links to change the messages on this page do not. they
all include the port that the proxy server is sending
on. I've tried to fix this myself, but
InitialiseMessages.inc seems to be the file that
affects this, but it doesn't seem to actually do anything.

------------------------- Additional comments ------------------------
Date: 2004-05-05 03:37
Sender: SF user vibber

You can edit that page and do a global search-and-replace to
the correct
URL. (Also you can regenerate messages using maintenance/
rebuildMessages.php but currently this requires some adjustments
to
LocalSettings.php to run cleanly; make sure it can't be run from
the
web!)

The problem is that the auto-detected $wgServer is put into those
links
when the page is generated at install time, so before you've
had a
chance to customize it.

I'm changing the summary of this bug report to reflect that we
should
make this more flexible.
Comment 1 Timwi 2004-09-03 19:42:37 UTC
*** Bug 315 has been marked as a duplicate of this bug. ***
Comment 2 Brion Vibber 2004-09-18 20:34:49 UTC
This bug causes FAQ issues, so really should get fixed for 1.4.

The first step was adding enough {{}} variables to cover the relevant stuff instead of interpolating PHP variables in the string literals, 
but they're still being substituted at MediaWiki:-namespace initialization time.
Comment 3 T. Gries 2004-09-23 00:33:42 UTC
I ran into the same problem under 1.4 shortly: in Languages.php I needed to use
{{SERVER}} in a message text XYZ to generate MediaWiki:XYZ page.

However:
wfMsg('XYZ') and MediaWiki:XYZ did not show "http://myserver" but showed
"http://localhost" as substitute.

Solution as suggested by Brion (luckily enough, I found it by myself):

If you need the server's name at installation or rebuildmessage.php time use
{{{{SERVER}}}} . All other variables are not affected, thus normal variable
quoting {{ ... }} appears to be sufficient.

If this information doubles Brion's, then please delete it. I just wanted to
confirm the findings and the ad-hoc solution.
Comment 4 Brion Vibber 2004-10-10 08:37:29 UTC
Fixed in head and REL1_3 cvs.
Comment 5 Brion Vibber 2005-05-29 09:31:54 UTC
*** Bug 2260 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links