Last modified: 2011-03-12 15:34:46 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2881 - Page Move no longer case-sensitive?
Page Move no longer case-sensitive?
Status: CLOSED DUPLICATE of bug 2556
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.5.x
PC All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-16 17:59 UTC by Martin Steiger
Modified: 2011-03-12 15:34 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Martin Steiger 2005-07-16 17:59:49 UTC
I can move TEST [1] to TEST2 [2] without any problems [3], however, the attempt
to move TEST2 to Test2 [4] results in the following error message:

«Source and destination titles are the same; can't move a page over itself.»

That is either a bug or a behaviour I would not expect since page titles are
supposed to be processed in a case-sensitive way by default.

[1] = http://www.zrhwiki.ch/wiki/TEST
[2] = http://www.zrhwiki.ch/wiki/TEST2
[3] = http://www.zrhwiki.ch/w/index.php?title=Spezial%3ALog&type=move&user=&page=
[4] = http://www.zrhwiki.ch/wiki/Spezial:Movepage/TEST2
Comment 1 Antoine "hashar" Musso (WMF) 2005-07-16 18:00:40 UTC
Works in REL1_4
Broken in CVS
Comment 2 Brion Vibber 2005-07-16 18:01:51 UTC
This has been reported multiple times and I've never been able to reproduce it, nor 
do I think it's possible given the code. Did you type "Test2" in the *reason* box 
instead of the *destination title* box? This produces exactly that error.

Please double-check, confirming exactly which box you're typing in.
Comment 3 Martin Steiger 2005-07-16 18:15:41 UTC
(In reply to comment #2)
> This has been reported multiple times and I've never been able to reproduce
it, nor 
> do I think it's possible given the code. Did you type "Test2" in the *reason* box 
> instead of the *destination title* box? This produces exactly that error.
> 
> Please double-check, confirming exactly which box you're typing in.

I changed the language of my wiki from German to English, and well, the bug
didn't occur. Changing back to German again, the attempt to move the page
resulted in the error message reported before.
Comment 4 Brion Vibber 2005-07-16 18:21:23 UTC
Changing $wgLanguageCode from 'en' to 'de' has no effect for me. Moving TEST2 to Test2 
continues to work.
Comment 5 Brion Vibber 2005-07-16 18:49:14 UTC

*** This bug has been marked as a duplicate of 2556 ***
Comment 6 Martin Steiger 2005-07-16 18:50:16 UTC
I have no idea why but after Brion move a page in my wiki, the problem does no
longer occur. Thanks! :D

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links