Last modified: 2006-06-11 10:42:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2757 - 'Page move completed' screen should contain link to original page with &redirect=no
'Page move completed' screen should contain link to original page with &redir...
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal enhancement with 10 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/MediaWik...
:
: 5070 5354 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 14:20 UTC by mikael79@yahoo.com
Modified: 2006-06-11 10:42 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description mikael79@yahoo.com 2005-07-08 14:20:39 UTC
Today, after moving page X to new title Y, you're taken to a page with two
links, to page X and to page Y. I think that the link to page X should prevent
the redirect to activate (some kind of &redirect=no in the URL?), because as it
is now, you basically have two links to the same page - the target.
Comment 1 Rob Church 2006-01-16 00:09:00 UTC
Fixed in CVS HEAD.
Comment 2 Rob Church 2006-01-16 02:34:43 UTC
Reverted code in HEAD following discussion with Brion, given that the method
used to implement this could have been better. Still open.
Comment 3 Melancholie 2006-02-12 03:12:17 UTC
Solution for impatient people like me: [[wikt:de:
MediaWiki:Pagemovedtext]]
Comment 4 Melancholie 2006-02-12 03:15:20 UTC
Link without wrap:
[[wikt:de:MediaWiki:Pagemovedtext]]
Comment 5 Tomasz G. Sienicki 2006-02-12 11:11:24 UTC
Tried before, doesn't work when there are spaces in titles
Comment 6 lɛʁi לערי ריינהארט 2006-02-12 13:18:21 UTC
If moved of images and categories would be enabeled again inline links must be used.
Comment 7 Melancholie 2006-02-12 23:34:20 UTC
Yes, that is correct; of course this has to be done by 
our developers! ;-) But I think it is better than 
nothing (see current version). -- Best regards, 
Melancholie
Comment 8 Melancholie 2006-02-13 01:24:06 UTC
See also: Bug 4110
Comment 9 Rob Church 2006-02-13 01:29:15 UTC
No, please do NOT spatter unrelated links to other bug reports. It makes an
incredible mess.
Comment 10 Melancholie 2006-02-13 01:47:05 UTC
That bug describes the cause of the wrapping problem 
from above, so it is related to my last comment! ;-)
Comment 11 Melancholie 2006-02-13 01:52:52 UTC
(In reply to comment #10)
> ..wrapping..

<del>wrapping</del> -> "disruption" of HTML links, if 
space characters are used
Comment 12 Melancholie 2006-02-13 03:02:14 UTC
Yippee! Now it works properly :-)

See:
[[wikt:de:MediaWiki:Pagemovedtext]]
Comment 13 Connel MacKenzie 2006-02-13 17:48:28 UTC
Works for me too.  Thanks Melancholie!
Comment 14 Melancholie 2006-02-25 14:15:02 UTC
*** Bug 5070 has been marked as a duplicate of this bug. ***
Comment 15 Melancholie 2006-03-13 15:22:17 UTC
Could someone, by using a script, change this on all wikis? Or how are MediaWiki
messages normally updated, making those changes?
Comment 16 Rob Church 2006-03-26 04:34:17 UTC
*** Bug 5354 has been marked as a duplicate of this bug. ***
Comment 17 Borgx 2006-06-11 09:08:59 UTC
(In reply to comment #12)
> Yippee! Now it works properly :-)
> 
> See:
> [[wikt:de:MediaWiki:Pagemovedtext]]

Fail if $1 contains space :(
Comment 18 mikael79@yahoo.com 2006-06-11 10:42:59 UTC
http://en.wiktionary.org/wiki/MediaWiki:Pagemovedtext seems to work even with
spaces.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links