Last modified: 2010-05-15 15:48:26 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2707 - Empty page after login/create user account; no login possible
Empty page after login/create user account; no login possible
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.9.x
PC Windows XP
: Normal major with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.familie-westerkamp.de/w/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-05 07:30 UTC by Jan Eglinger
Modified: 2010-05-15 15:48 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jan Eglinger 2005-07-05 07:30:59 UTC
I installed MediaWiki 1.5beta1 on an Apache/1.3.29 (Unix) environment with CGI
PHP Version 4.3.10 and external MySQL 4.0.20 (not localhost).

After installation page rendering, login and user account creation worked OK.
When I wanted to restrict the page access (see bottom *),
- loading new (uncached) pages resulted in a white page containing the letters
"" before redirecting to the actual page.
- trying to login resulted in an empty page without any redirection, making it
impossible to login.

Undoing all the changes in DefaultSettings.php and LocalSettings.php did NOT fix
this problem.

I tried as well with Firefox (1.0.4) and with Internet Explorer (6.0) from
WindowsXP.


*Access restriction was done:
by commenting (#) the following lines in DefaultSettings.php :

  #$wgGroupPermissions['*'    ]['createaccount']   = true;
  #$wgGroupPermissions['*'    ]['read']            = true;
  #$wgGroupPermissions['*'    ]['edit']            = true;

and entering the following lines into LocalSettings.php :

  # Pages anonymous (not-logged-in) users may see
  $wgWhitelistRead = array ("Main Page", "Special:Userlogin", "Wikipedia:Help");
Comment 1 Brion Vibber 2005-07-05 07:36:53 UTC
Make sure your text editor has not added a byte order mark to the beginning of any of the files, and delete it if there is one.
Comment 2 Ars 2007-02-06 13:14:49 UTC
I did the same with MediaWiki 1.9.0 and encountered the same problem. Problem
appears only on Internet Explorer 6.0+ (with firefox everything works fine). 
I edited files using FAR - it does not add anything extra.
Comment 3 Brion Vibber 2007-02-06 18:24:52 UTC
If you have the same problem, then you *do* have a BOM added. Remove it.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links