Last modified: 2011-02-01 22:30:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27021 - Re-uploading a deleted file fails, warning cannot be ignored
Re-uploading a deleted file fails, warning cannot be ignored
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Uploading (Other open bugs)
1.17.x
All All
: High major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 27090 (view as bug list)
Depends on:
Blocks: 26611
  Show dependency treegraph
 
Reported: 2011-01-28 21:17 UTC by Gregor Hagedorn
Modified: 2011-02-01 22:30 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Gregor Hagedorn 2011-01-28 21:17:19 UTC
Upload a file to mediawiki 1.18alpha (r79596)

Delete that file.

Reupload a file of the same name. A warning appears, which is helpful. In the upload form, at this point, the filename is still present under "Source filename:"

Click at bottom of form on  "Ignore warning and save file anyway". Now the upload fails with message above the (now empty!) "Source filename:" : "The file you uploaded seems to be empty. This might be due to a typo in the file name. Please check whether you really want to upload this file."

Repeatable...
Comment 1 Mark A. Hershberger 2011-01-29 02:38:45 UTC
Thanks for the bug report.  We're in the middle of the release of 1.17 right now, though, so it may take a week or so for us to get to this.
Comment 2 Gregor Hagedorn 2011-01-29 10:04:26 UTC
Agreed for 1.18, but please check the behavior under 1.17. The same or very similar bug occurred in a much earlier 1.17 version (SVN number not know). It disappeared later after an update, so I did not report.
Comment 3 Bryan Tong Minh 2011-01-29 13:46:29 UTC
I'm marking this as depending on bug 26611, as somebody should at least check if this problem occurs in 1.17 as well. I suspect it will as I do not remember significant changes to the upload code in 1.18.
Comment 4 Bryan Tong Minh 2011-01-29 15:36:19 UTC
Can confirm, both on 1.17 and 1.18.
Comment 5 Bryan Tong Minh 2011-01-29 21:44:56 UTC
Fixed in r81197.

@mah, in general you can assign upload related stuff that needs investigating or fixing before the 1.17 release to me.
Comment 6 Bryan Tong Minh 2011-01-29 23:10:42 UTC
*** Bug 26214 has been marked as a duplicate of this bug. ***
Comment 7 Bryan Tong Minh 2011-02-01 22:30:56 UTC
*** Bug 27090 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links