Last modified: 2006-08-18 19:39:34 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2611 - (Safari) links to subsection ignore specified subsection
(Safari) links to subsection ignore specified subsection
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
Macintosh Mac OS X 10.4
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 18:35 UTC by Rick Block
Modified: 2006-08-18 19:39 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rick Block 2005-06-29 18:35:58 UTC
On the en wikipedia, using classic skin wih Safari (OS X), links to subsections of articles seem to go to the main article but not the 
indicated subsection.  See, for example, [[Wikipedia_talk:Categories%2C_lists%2C_and_series_boxes]], at the bottom (shouldn't be 
hard to reproduce, I haven't seen it work at all since 1.5 was put up).  This also affects the rediplay of an article after editing a 
section (which I don't think worked before 1.5 either).
Comment 1 en:brian0918 2005-06-29 21:58:42 UTC
Works in Red Hat Linux with the latest Firefox.
Comment 2 Brion Vibber 2005-06-29 22:03:23 UTC
I can confirm this with Safari 2.0 on Mac OS X 10.4.1, logged in on en.wikipedia.org with either 
MonoBook or Classic skin selected.

Clicking the link w/ this URL off of the page mentioned above, I am not taken to the section:
http://en.wikipedia.org/wiki/
Wikipedia_talk:Navigational_templates#Many_navigational_templates_in_violation_of_WP:CSL.
2C_what_to_do.3F

Note that clicking the line in the TOC once on the page works fine, although it's the same URL.

This may be a browser bug, however.
Comment 3 Brion Vibber 2005-11-05 07:17:57 UTC
Looks like it was probably a browser bug, noticed this in some other places as well.

Now working with Safari 2.0.2 (416.12), Mac OS X 10.4.3; resolving as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links