Last modified: 2010-05-15 15:38:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T4605, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 2605 - Section editing by right-click is broken
Section editing by right-click is broken
Status: RESOLVED DUPLICATE of bug 2534
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2005-06-29 14:59 UTC by Dan Smith
Modified: 2010-05-15 15:38 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Dan Smith 2005-06-29 14:59:40 UTC
Since the upgrade to MediaWiki 1.5, section editing by right-clicking on the
header (enabled in the "editing" tab of one's user preferences) no longer works,
though the [edit] links still appear to work well enough.
Comment 1 Ævar Arnfjörð Bjarmason 2005-06-29 15:13:41 UTC

*** This bug has been marked as a duplicate of 2534 ***
Comment 2 River Tarnell 2005-06-29 15:20:46 UTC
reopening because the reporter indicated they have section edit links enabled, 
and bug 2534 is about JS section editing not working only when section edit 
links are disabled. 
Comment 3 Antoine "hashar" Musso (WMF) 2005-07-05 00:24:27 UTC
Works for me with:
 - lastest CVS.

Please double check:
 - javascript is enabled in your browser
 - edit on right click is checked in your preferences
 - you are actually using the correct mouse button and clicking on the header
(ok just kidding on that last check)

Eventually purge your browser cache.
Uncheck preference, save, recheck, save + clean browser cache.
Comment 4 Dan Smith 2005-07-05 14:18:19 UTC
Yes, now it works with [edit] links enabled, but when I disable those,
right-clicking still doesn't work.
Comment 5 Niklas Laxström 2005-07-05 19:29:11 UTC
Marking as duplicate again

*** This bug has been marked as a duplicate of 2534 ***

Note You need to log in before you can comment on or make changes to this bug.