Last modified: 2005-06-28 22:29:46 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2583 - 1.4-1.5 some images accidentally deleted off server
1.4-1.5 some images accidentally deleted off server
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
unspecified
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 18:09 UTC by Duncan Harris
Modified: 2005-06-28 22:29 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Duncan Harris 2005-06-28 18:09:08 UTC
1.4-1.5 upgrade a number of images have disppeared including:

*[[:Image:USA transport corps steam loco 5820.jpg]]
*[[:Image:BN 251 IL Eola.jpg]]

This is not to do with the image appearing in a 1x1 size.  Rather it just vanished.

For example, Image:USA transport corps steam loco 5820.jpg was originally uploaded 
around 10 September 2004 by me.  However the page history states that the image 
description page was created on 21 June 2005, though I may have edited it then, I did 
not create it then.  According to Brion Vibber the upload log is also missing this, 
though I haven't checked it thoroughly.

I have two questions:

1. Which other images did it effect?
2. How can I get my image back?
Comment 1 Brion Vibber 2005-06-28 18:16:09 UTC
Second one looks fine. Was it re-uploaded?

When did you upload them? On en.wikipedia.org or commons?
Comment 2 Brion Vibber 2005-06-28 18:18:45 UTC
Found in files for enwiki:
-rw-rw-r--    1 apache   wikidev   1446914 Sep 10  2004 USA_transport_corps_steam_loco_5820.jpg

There's no database entry for it, though. Possibly an old bug with uploads, or an old bug with deletions 
(eg if it was deleted a long time ago but the file wasn't removed).
Comment 3 peter green 2005-06-28 18:34:51 UTC
it sounds to me like a program needs to be written to scan the images dir and
create db entries for any files without them.
Comment 4 Duncan Harris 2005-06-28 20:02:26 UTC
[[:Image:USA transport corps steam loco 5820.jpg]]
was uploaded to w:en: probably sometime between 7-10 September 2004.

[[:Image:BN 251 IL Eola.jpg]] was reuploaded, by Slambo from his own hard drive.  He probably uploaded the 
original around 8 June 2005 to w:en: since that is the time that the photo first appears in articles and in 
his gallery.
Comment 5 Brion Vibber 2005-06-28 22:29:46 UTC
I've set up a script to crawl the upload directory and add entries, and the example image is now 
loadable.

I'll run this on the others and include it in the upgrade regime.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links