Last modified: 2011-07-17 05:22:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2469 - No line break between template and link when separated by whitespace in wikicode
No line break between template and link when separated by whitespace in wikicode
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.8.x
All All
: Low normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikinews.org/w/index.php?ti...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 01:05 UTC by andrewpmk
Modified: 2011-07-17 05:22 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description andrewpmk 2005-06-21 01:05:33 UTC
When I create a page with a template, which includes one unnamed parameter
followed by a blank line and then immediately thereafter a link (interwiki or
regular), the whitespace is not shown. A quick and dirty hack, by enclosing the
template with <p></p>, fixes the problem.

Example wikicode which creates this problem:

{{date|June 2, 2005}}

[[w:Link]] blah blah.

----------------------

Example wikicode which does not create this problem:

{{dateline|date=June 2, 2005|location=wherever}}

[[w:Link]] blah blah.

I have only been able to reproduce this on Wikinews.
Comment 1 lɛʁi לערי ריינהארט 2005-06-21 17:25:52 UTC
I made a test at http://test.leuksman.com/index.php?title=Bugzilla_2469 where
similar behaviour is experienced.

[[wikinews:en:Tartan_Day_festivities_April_6_in_New_York&oldid=75945]] relates
to an older revision. If you click on *article* you will *not* see the error.

Rendering for templates is somthing very sensible. No *extra* newlines should be
added *automatically* because this would break rendering of templates in
identations using #, :, combinations of boths, templates in table cells etc.

It is crucial to know how temlates behave and how they render. Adaptations for
*individual* needs should be made to the templates and *not* to rendering except
for *real* bugs.

Regards Reinhardt [[user:gangleri]]
Comment 2 Jimmy Collins 2006-09-27 17:44:50 UTC
Tested with 1.8alpha (r16658) - the bug still exists. Version changed to 1.8-svn.
Comment 3 Felix Pahl 2010-04-19 06:52:13 UTC
This seems to have been fixed in the meantime -- I was unable to reproduce it on either en.wikipedia.org or en.wikinews.org.
Comment 4 Dan Collins 2011-07-17 05:22:30 UTC
Reported fixed by Felix Pahl.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links