Last modified: 2010-08-08 06:03:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T26107, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 24107 - Add UDP messages on comment/status change
Add UDP messages on comment/status change
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CodeReview (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch, patch-reviewed
Depends on: 24104
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 23:26 UTC by John Du Hart
Modified: 2010-08-08 06:03 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Patch for sending UDP on comments and change status (2.44 KB, patch)
2010-06-23 23:26 UTC, John Du Hart
Details
Improved patch with proper usage of wfMsg and truncated comments (2.34 KB, patch)
2010-06-24 04:31 UTC, John Du Hart
Details
Patch version 3 (2.76 KB, patch)
2010-06-24 21:35 UTC, John Du Hart
Details

Description John Du Hart 2010-06-23 23:26:33 UTC
Created attachment 7505 [details]
Patch for sending UDP on comments and change status

Right now the robot codurr in #mediawiki echos new comments on revisions. It does this with database queries which is slow and inefficient. This patch sends out an UDP packet like for Recent Changes as soon as the comment is posted or the status is changed. The variable for the UDP Address/Port/Prefix is separate than the one for RC.
Comment 1 John Du Hart 2010-06-24 04:31:13 UTC
Created attachment 7506 [details]
Improved patch with proper usage of wfMsg and truncated comments
Comment 2 Niklas Laxström 2010-06-24 06:08:12 UTC
(In reply to comment #1)
> Created an attachment (id=7506) [details]
> Improved patch with proper usage of wfMsg and truncated comments

+$wgCRUDPAddress = false;
+$wgCRUDPPort = false;
+$wgCRUDPPrefix = '';

I'd spell the CodeReview in full. Maybe also encapsulate the RecentChange::sendToUDP(...); line to keep those globals in one place only.
Comment 3 John Du Hart 2010-06-24 12:22:25 UTC
(In reply to comment #2)
 > I'd spell the CodeReview in full. Maybe also encapsulate the
> RecentChange::sendToUDP(...); line to keep those globals in one place only.

Sorry but what do you mean by "encapsulate the
> RecentChange::sendToUDP(...); line", move it to its own function?
Comment 4 Niklas Laxström 2010-06-24 14:25:50 UTC
Yeah, I'd make a new function.
Comment 5 John Du Hart 2010-06-24 21:35:20 UTC
Created attachment 7513 [details]
Patch version 3

This patch should address your requests. Let me know if it's missing anything.
Comment 6 X! 2010-08-08 05:32:20 UTC
r70660
Comment 7 p858snake 2010-08-08 06:03:21 UTC
keywords: s/need-review/reviewed/.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links