Last modified: 2010-05-23 18:16:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23212 - SMW format=template queries html not terminating properly?
SMW format=template queries html not terminating properly?
Status: RESOLVED DUPLICATE of bug 23297
Product: MediaWiki extensions
Classification: Unclassified
Semantic MediaWiki (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Markus Krötzsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 21:09 UTC by Neill Mitchell
Modified: 2010-05-23 18:16 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Neill Mitchell 2010-04-16 21:09:05 UTC
I want the sections of my 
website automatically appear in my MW sidebar as they are created by a 
SMW form.

So in http://llocalhost/mediawiki/index.php/Mediawiki:Sidebar I have:

* navigation
** mainpage|mainpage-description
** portal-url|portal
** currentevents-url|currentevents
** recentchanges-url|recentchanges
** randompage-url|randompage
** helppage|help
{{#ask:
[[Category:Sections]]
[[Title::+]]
|?Section Link#-
|link=none
|format=template
|template=Sidebar Query
}}

The Sidebar Query Template is:

** {{{1}}}|{{{2}}}

The result is that I get the section names and their links appearing in 
the sidebar as expected, except for one problem. The last one has 
[[SMW::on]] after it. e.g.:

Section1
Section2
Section3
Section4[[SMW::on]]

Any idea where the [[SMW::on]] is coming from? I have a suspicion that 
format=template queries are not terminating correctly elsewhere as well.

I'm using SMW 1.4.3 and MW 1.15.1.
Comment 1 Markus Krötzsch 2010-05-23 18:16:32 UTC

*** This bug has been marked as a duplicate of bug 23297 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links