Last modified: 2009-12-14 18:55:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21831 - Search doesn't find files
Search doesn't find files
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
1.16.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-12 23:44 UTC by Subfader
Modified: 2009-12-14 18:55 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Subfader 2009-12-12 23:44:42 UTC
I can't explain the behaviour but here it is.

Try to find the following (existing) files on mediawiki.org using the standard search.
Testnameforsearch foo.png
Anothertestname.png
Funkadelia test name.png
Iuftrekdjhlsfbhs.png

linked here: http://www.mediawiki.org/wiki/User:Subfader/2/3/4

They are not found. Not even Iuftrekdjhlsfbhs.png which doesn't include stop words.

The tricky thing is, you will only find this bug when you know the files you search for does exist and you wonder why it doesn't show up in the result.

As a wider test, Iuftrekdjhlsfbhs.png couldn't be found after upload on my wiki, on mediawiki.org and commons.wikimedia.org
Comment 2 Max Semenik 2009-12-14 17:22:02 UTC
Which search engine does your wiki use? Note that on Wikimeadia it could take some time before things are indexed.
Comment 3 Subfader 2009-12-14 18:55:44 UTC
Guess so about the indexing. I don't use Lucene. No search engine installed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links