Last modified: 2011-03-13 18:06:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2154 - <code> tags should render the same as <pre>
<code> tags should render the same as <pre>
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Lowest enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 00:56 UTC by Damien
Modified: 2011-03-13 18:06 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Damien 2005-05-12 00:56:42 UTC
It seems that the contents of <pre> tags get by without processing. It seems logical that 
<code> tags should follow this. I have included a test case:



<pre><h1>This is an example HTML snippet.</h1></pre>

The following tag <code><h1></code> should be rendered in a similar method to the above.
Comment 1 Ævar Arnfjörð Bjarmason 2005-05-14 19:28:33 UTC
WONTFIX, X?HTML is supposed to be rendered inside <code> but not inside <pre>,
this is standard behaviour for these tags both on MediaWiki pages and outside them.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links