Last modified: 2009-11-02 19:24:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21308 - Can't seem to list multiple properties when using "Has display parameters".
Can't seem to list multiple properties when using "Has display parameters".
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
SemanticDrilldown (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Yaron Koren
http://smw.referata.com/wiki/Special:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-27 10:57 UTC by Dan Bolser
Modified: 2009-11-02 19:24 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Bolser 2009-10-27 10:57:08 UTC
I tried passing various different values to the "Has display parameters" property here:

http://smw.referata.com/wiki/Category:Events


(see the page history (or below) for the specific details). However, none of the combinations that I tried resulted in output of more than one property here:

http://smw.referata.com/wiki/Special:BrowseData/Events


This is unexpected, because the examples I saw on the mailing list showed several properties listed with table format. (Actually, I'd like list format, but the issue is the same).

Whatever I do, I only see one property (the first) listed.

W'sup with that?



[[Has display parameters::?Has country=; ?Has city; format=table | ]]
[[Has display parameters::?Has city=; ?Has country | ]]
[[Has display parameters::?Has city; ?Has country | ]]
[[Has display parameters::?Has city; ?Has country; format=table | ]]
[[Has display parameters::? Has city=; ? Has country=; format=table | ]]
[[Has display parameters::? Has city; ? Has country= | ]]
[[Has display parameters::? Has city=; ? Has country= | ]]
...
Comment 1 Yaron Koren 2009-11-02 19:24:04 UTC
This was a problem with the handling of whitespaces after the semicolons; it's been fixed now, in version 0.6.2.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links