Last modified: 2005-05-09 21:15:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2116 - Wiki markup not forming bulleted lists regularly in places
Wiki markup not forming bulleted lists regularly in places
Status: RESOLVED DUPLICATE of bug 2094
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://la.wiktionary.org/wiki/U
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-08 19:53 UTC by Muke Tever
Modified: 2005-05-09 21:15 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Muke Tever 2005-05-08 19:53:37 UTC
At the bottom of several pages on the Latin Wiktionary there is supposed to be a 
bulleted list after a disambiguation template.  However the bulleted lists are not 
forming regularly.  On [[wikt:la:U]] for example, the code shows:

* {{en}}: {{cito-d|en|u}}
* {{nl}}: {{cito-d|nl|u}}
* {{es}}: {{cito-d|es|u}}

But only the line with {{nl}} ("Batave") receives a bullet, even though it (sometimes) 
displays correctly on preview.  

I thought it might perhaps be because of the disambiguation template, but this problem 
was around before the template even came into existence, e.g. here:

http://la.wiktionary.org/w/index.php?title=De&oldid=3394

...where there is also a three-item bulleted list, though in this case only the *first* 
item received a bullet.  (In later versions of this latter page I was able to 'fix' 
display only by using raw UL and LI tags.)
Comment 1 Ævar Arnfjörð Bjarmason 2005-05-08 19:56:35 UTC
Please supply a simplified testcase, preferrably one that does not use templates.
Comment 2 Michael Keppler 2005-05-08 20:22:47 UTC
This bug may be related to bug 2094 (but I'm not sure). In both bugs the output
for some templates is not as expected and in both cases the wrongly rendered
parts contain additional <p>-tags.
Comment 3 Muke Tever 2005-05-08 20:39:27 UTC
I am sorry, I do not know (yet) how to reliably reproduce the bug.  I copied and pasted the offending 
section of [[wikt:la:U]] to its own page, [[wikt:la:Victionarium:Harenarium/lists]] and it displays 
perfectly normally.  (I will keep trying though.)

Other pages that do not produce the lists normally: [[wikt:la:Lector]], [[wikt:la:Tantalum]], 
[[wikt:la:Technetium]]... 
Comment 4 Muke Tever 2005-05-09 00:17:26 UTC
I took the smallest subset of the [[wikt:la:U]] that exhibited any 
characteristics of this bug, and did subst: on the templates to see what was 
going on.  (Result: [[wikt:la:Victionarium:Harenarium/U]].) It turns out that 
somewhere a line that is straightforwardly 

* {{es}}:  ...

somehow expanded to:

*
[[Project:Lingua Hispanica|Hispanice]]: ... 

with a linebreak thrown in, which explains why the bullet isn't created.  

What I don't know is where the line break comes from.  (Perhaps it is related to 
the extra linebreaks in bug 2094 ...)
Comment 5 Michael Keppler 2005-05-09 21:15:45 UTC
Resolving as duplicate of bug 2094. The bug occurs on second inclusion of the
{{es}} template in this case but has the same reason as 2094.

*** This bug has been marked as a duplicate of 2094 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links