Last modified: 2011-06-28 15:50:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20526 - Resulting book from Wikisource still has interwiki links
Resulting book from Wikisource still has interwiki links
Status: RESOLVED DUPLICATE of bug 19838
Product: MediaWiki extensions
Classification: Unclassified
Collection (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: PediaPress Development Team
:
: 24897 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-07 02:31 UTC by Tran Vinh Tan
Modified: 2011-06-28 15:50 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
A example on vi.wikisource that interwiki links still show on PDF (235.68 KB, application/pdf)
2009-09-14 12:17 UTC, Tran Vinh Tan
Details

Description Tran Vinh Tan 2009-09-07 02:31:54 UTC
When I export books in PDF or ODF formats in Wikisource, if the article has interwiki links, they will show in the book. This problem does not occur in Wikipedia. I think interwiki links should be omit from the books.
Comment 1 Volker Haas 2009-09-14 10:33:49 UTC
This issue has probably been fixed. If there still is a problem with interwiki links please provide an example to allow debugging.
Comment 2 Tran Vinh Tan 2009-09-14 12:17:30 UTC
Created attachment 6550 [details]
A example on vi.wikisource that interwiki links still show on PDF

Still has error, this is an example.
Comment 3 Tran Vinh Tan 2009-09-14 12:18:45 UTC
I reopen this bug because there's still error. Please take a look at the 4th page of the attachment. I have just created it after receiving the notification email from BugZilla.
Comment 5 Volker Haas 2010-07-26 10:25:06 UTC
The problem seems to be that the API on wikisource returns an empty interwikimap. Therefore interwiki links can not be detected.

See the difference:

* interwikimap on en.wikipedia http://en.wikipedia.org/w/api.php?action=query&meta=siteinfo&siprop=interwikimap

* no interwikimap on vi.wikisource: http://vi.wikisource.org/w/api.php?action=query&meta=siteinfo&siprop=interwikimap

==> The solution is probably to fix the configuration of the mediawiki. If a correct interwikimap is returned by the API the interwiki links can be handled correctly in the PDF.
Comment 6 Roan Kattouw 2010-08-03 19:57:26 UTC
(In reply to comment #5)
> The problem seems to be that the API on wikisource returns an empty
> interwikimap. Therefore interwiki links can not be detected.
> 
> See the difference:
> 
> * interwikimap on en.wikipedia
> http://en.wikipedia.org/w/api.php?action=query&meta=siteinfo&siprop=interwikimap
> 
> * no interwikimap on vi.wikisource:
> http://vi.wikisource.org/w/api.php?action=query&meta=siteinfo&siprop=interwikimap
> 
> ==> The solution is probably to fix the configuration of the mediawiki. If a
> correct interwikimap is returned by the API the interwiki links can be handled
> correctly in the PDF.

I suspect the problem is in the API module, which IIRC queries the database but doesn't think to access the interwiki cache.
Comment 7 Nemo 2010-11-22 19:05:42 UTC
*** Bug 24897 has been marked as a duplicate of this bug. ***
Comment 8 Volker Haas 2011-06-24 10:57:27 UTC
I would like to remove the pediapress dev team from the assignees list. The bug seems to be in the MediaWiki API/configuration. Who would be the correct assignee?
Comment 9 Roan Kattouw 2011-06-25 12:52:41 UTC
(In reply to comment #8)
> I would like to remove the pediapress dev team from the assignees list. The bug
> seems to be in the MediaWiki API/configuration. Who would be the correct
> assignee?
It seems this is a duplicate of bug 19838 then, is that right?
Comment 10 Nemo 2011-06-25 14:43:08 UTC
(In reply to comment #9)
> It seems this is a duplicate of bug 19838 then, is that right?

Seems sensible. We need someone to look at it, though...

*** This bug has been marked as a duplicate of bug 19838 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links