Last modified: 2010-05-15 15:29:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 205 - Wrong links on generated All_system_messages page
Wrong links on generated All_system_messages page
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.3.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-24 09:48 UTC by Michael Keppler
Modified: 2010-05-15 15:29 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Michael Keppler 2004-08-24 09:48:48 UTC
I did an upgrade from 1.3 beta 2 to 1.3.1. In this process a page
"MyWikiName:All_system_messages" was generated. The links on that page to the
pages with the system messages are all wrong, they point to the absolute URL
localhost/wikidirectory/... instead of using servername/wikidirectory/... or
even better using only a relative URL.
A possible reason for this could be that I called the upgrade web page url via
localhost directly on that server instead of via its external servername.
Comment 1 Brion Vibber 2004-09-18 20:31:29 UTC
The All_system_messages page is really slow and also unreliable due to the issue noted in this bug. It's been superceded by [[Special:
Allmessages]], which as of 1.3.3 is also much, much faster. Since the edit links are dynamically generated they will always use the 
current configuration of the wiki.

Use Special:Allmessages rather than the old page (remove it or redirect it if you've got it lying around still.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links