Last modified: 2010-05-15 15:37:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2039 - Missing ';' in translation of month 'May' makes links to {{CURRENTMONTHNAME}} ugly
Missing ';' in translation of month 'May' makes links to {{CURRENTMONTHNAME}}...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.5.x
All All
: Highest normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://lt.wikipedia.org/wiki/Prad%C5%...
: patch
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-01 07:16 UTC by Andrius Ramanauskas
Modified: 2010-05-15 15:37 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
added missing ';' (695 bytes, patch)
2005-05-01 07:17 UTC, Andrius Ramanauskas
Details
Fix which replaces HTML chars with UTF-8 ones (1.81 KB, patch)
2005-05-01 07:59 UTC, Andrius Ramanauskas
Details

Description Andrius Ramanauskas 2005-05-01 07:16:16 UTC
In lithuanian language May is translated to "Gegu&#382ės", but as ';' is
missing (should be "Gegužės"), link [[{{CURRENTMONTHNAME}}
{{CURRENTDAY}}]] becomes invalid and in 1.4rc1 is shown ugly (shows "Gegu&#382ės
1", links to "Gegu&").
Comment 1 Andrius Ramanauskas 2005-05-01 07:17:12 UTC
Created attachment 485 [details]
added missing ';'
Comment 2 Brion Vibber 2005-05-01 07:21:08 UTC
Using HTML entities here is incorrect anyway as these should be plain text.
Can you provide a patch that uses the correct UTF-8 plain text encoding?
Comment 3 Andrius Ramanauskas 2005-05-01 07:59:28 UTC
Created attachment 486 [details]
Fix which replaces HTML chars with UTF-8 ones
Comment 4 JeLuF 2005-05-01 08:25:25 UTC
Fixed in CVS HEAD rev 1.23
CVS REL1_4 rev 1.10.2.6
Deployed to wikipedia.org

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links