Last modified: 2009-08-10 17:37:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20130 - Special:Tags making Special:Log HTML malformed
Special:Tags making Special:Log HTML malformed
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Andrew Garrett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-08 14:17 UTC by Derk-Jan Hartman
Modified: 2009-08-10 17:37 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2009-08-08 14:17:13 UTC
For instance on the Special:Log page i see this:


<option value="11">November</option> 
<option value="12">December</option></select> 
<p><a href="/wiki/Special:Tags" title="Special:Tags">Tag</a> filter:&nbsp;<input name="tagfilter" size="20" value="" /></p> 
 
<input type="submit" value="Go" /></p> 
</fieldset></form><p>No matching items in log.
</p><div class="printfooter"> 

The <p>'s and endtags are clearly "confused" you might say. The problem is not visible on test.wikipedia.org, not sure if that is because I have the "patrol log" links before the "go" button, or if there is another reason.
Comment 1 Platonides 2009-08-08 14:30:18 UTC
The problem is SpecialTags inserting itself into an already existing <p> (document type does not allow element "p" here).
w3c validator reports the error both on testwiki and enwiki.

Comment 2 Brion Vibber 2009-08-10 17:23:08 UTC
Andrew, can you take a peek at this? Probably easy cleanup.
Comment 3 Andrew Garrett 2009-08-10 17:37:19 UTC
Cleaned up in r54730.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links