Last modified: 2009-08-17 17:43:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20027 - Page move with special characters fails in some skins
Page move with special characters fails in some skins
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 20172 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-01 00:20 UTC by Jens K Andersen
Modified: 2009-08-17 17:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jens K Andersen 2009-08-01 00:20:47 UTC
In the skins Classic, Cologne blue and Nostalgia, the url when clicking the move link on many page names with percent-encoded characters is wrong and causes the error message:
"No target
You have not specified a target page or user on which to perform this function."

For example, on the article Lay's at
http://en.wikipedia.org/wiki/Lay%27s
two correctly working move url's would be
http://en.wikipedia.org/wiki/Special:MovePage/Lay%27s
or
http://en.wikipedia.org/w/index.php?title=Special:MovePage&target=Lay%27s
but in Classic, Cologne blue and Nostalgia it is
http://en.wikipedia.org/w/index.php?title=Special:MovePage&target=Lay%2527s

It says %25 instead of %. It can happen for each % if there are more. The percent-encoding of % is %25 so maybe the url has been percent-encoded twice in a row.
In all other skins in the English Wikipedia, the move url is the correctly working
http://en.wikipedia.org/wiki/Special:MovePage/Lay%27s

This problem was reported 30 July 2009 at http://en.wikipedia.org/wiki/Wikipedia:Help_desk#Moving_a_page with permanent link http://en.wikipedia.org/w/index.php?title=Wikipedia:Help_desk&oldid=305260677#Moving_a_page
Comment 1 Leinad 2009-08-01 12:22:46 UTC
Issue already fixed in r53385.
Comment 2 Jens K Andersen 2009-08-17 17:28:53 UTC
*** Bug 20172 has been marked as a duplicate of this bug. ***
Comment 3 Jens K Andersen 2009-08-17 17:39:23 UTC
The same problem is still there.
Comment 4 Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-08-17 17:43:29 UTC
r53385 is not yet live on Wikimedia sites.  The fix has been committed, it just hasn't been pushed out to Wikipedia yet.  If you think this is actually not fixed in the software at trunk, please reopen.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links