Last modified: 2010-05-15 15:33:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1966 - wikitext table parser barfs on html zero char
wikitext table parser barfs on html zero char
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.4.x
Other Windows XP
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/User:Joh...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-24 14:14 UTC by Finlay McWalter
Modified: 2010-05-15 15:33 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Finlay McWalter 2005-04-24 14:14:37 UTC
The following wikitext

{| style="background:green"
|�
|}

breaks the wikitext html parser.  All subsequent wikitext isn't shown, and the
generated html doesn't close the table markup properly; so that "green"
background bleeds into the page elements following the rendered wikitext (nasty
on classic skin, very nasty on monobook).

Note: I tested this on en.wikipedia.org and meta.wikimedia.org and it happens on
both.  It >doesn't< happen on my home 1.4.2 installation (which handles it
perfectly well).  The wikimedia servers run PHP 4.3.11, I run PHP 5.0.4
(apache2handler), so I guess it's a difference in the PHP libraries.
Comment 1 JeLuF 2005-04-24 14:18:09 UTC
Duplicate of Bug http://pecl.php.net/bugs/bug.php?id=4202

The &#x0; confuses tidy, not MediaWiki.

Closed bug as this has to be fixed by tidy team.
Comment 2 Alphax 2005-04-25 09:13:44 UTC
Appears to be a duplicate of [[Bugzilla:1938]]
(http://bugzilla.wikipedia.org/show_bug.cgi?id=1938)
Comment 3 Brion Vibber 2005-04-27 07:35:37 UTC
Installed patched tidy extension, works now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links