Last modified: 2009-07-19 17:51:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19511 - 404 error when navigating away from the mobile site to regular Wikipedia
404 error when navigating away from the mobile site to regular Wikipedia
Status: RESOLVED FIXED
Product: Wikimedia Mobile
Classification: Unclassified
Retired (Ruby) Gateway (Other open bugs)
.5
All All
: Normal major (vote)
: ---
Assigned To: Hampton Catlin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 06:25 UTC by Andrew "FastLizard4" Adams
Modified: 2009-07-19 17:51 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Andrew "FastLizard4" Adams 2009-07-04 06:25:42 UTC
From http://en.m.wikipedia.org/wiki/::Home, clicking either "View this page on regular Wikipedia" or "Permanently disable mobile site" yields a 404 error.  Clicking "View this page..." takes you to http://en.wikipedia.org/w/mobileRedirect.php?to=http://en.wikipedia.org/wiki/Main_Page and "Permanently disable mobile site" adds &expires_in_days=3650 to the end of the same URL.  Because there is no other way to get to regular Wikipedia, it essentially prevents mobile users from going to regular Wikipedia.

Discovered using Safari on an iPod Touch running iPhone OS 3.0 (7A341).
Comment 1 Brion Vibber 2009-07-06 18:37:28 UTC
Sounds like one or more servers didn't get their software updates installed properly and are missing the files -- probably need a sync-common-all, or check if some boxes aren't allowing login or otherwise borked.
Comment 2 Hampton Catlin 2009-07-19 17:51:08 UTC
I believe this issue has been resolved and the redirect script is now properly in place.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links