Last modified: 2010-05-15 15:33:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1869 - Class 'unlistedspecialpage' vs. Turck MMCache
Class 'unlistedspecialpage' vs. Turck MMCache
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.4.x
PC Linux
: Lowest minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-10 23:35 UTC by Jean-Christophe Heger
Modified: 2010-05-15 15:33 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Replace mmcache with eAccelerator (7.30 KB, patch)
2005-05-19 19:38 UTC, Bart Vanbrabant
Details

Description Jean-Christophe Heger 2005-04-10 23:35:49 UTC
Installed apps:
- Apache 2.0.50
- PHP 5.0.2
- Turck MMCache 2.4.7-CVS
on a Mandrake 10.1

I get this error on "unlistedspecialpages" class call:

[client 172.19.10.50] PHP Fatal error:  Class 'unlistedspecialpage' not found in
/var/www/html/mediawiki-1.4.0/includes/SpecialPage.php on line 26, referer:
http://intranet.lan.lord-of-rings/mediawiki/index.php/User:172.19.10.50

Once Turck MMCache is disabled, everything works fine.
Comment 1 Christoph Neuroth 2005-04-22 08:40:36 UTC
Same Problem here. 
A workaround *should* be to set 
mmcache.filter = "!*SpecialPage.php" 
in 99_mmcache.ini, but for some Reasons it doesn't work. 
 
I hope someone can fix this soon as mmcache is *really* good in speeding up mediawikis... 
Comment 2 Brion Vibber 2005-04-22 08:46:32 UTC
Also, have you tried eAccelerator? I've the impression that Turck MMCache isn't really well tested with 
PHP 5, and it's no longer being maintained since the last release in late 2003.
Comment 3 Christoph Neuroth 2005-04-22 09:16:42 UTC
 I tried installing php5-eAccelerator using Mandrake 10.2 wich fails to load: 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/extensions/eaccelerator.so' - /usr/lib/php5/extensions/eaccelerator.so: undefined symbol: php_sprintf 
in Unknown on line 0 
 
Maybe self-compiling eAccelerator might help... 
Comment 4 Christoph Neuroth 2005-04-22 09:18:25 UTC
(In reply to comment #3) 
>  I tried installing php5-eAccelerator using Mandrake 10.2 wich fails to load:  
I meant Madnrake 10.2 rpms actually 
Comment 5 Christoph Neuroth 2005-04-22 17:18:04 UTC
I wasn't able to install eAccellerator but I tried this on a Mandrake box with php4 and it works fine with php-mmcache, so I guess using eAccelerator *should* solve this 
problem for php5-users as this seems to be a problem with mmcache and php5. 
Comment 6 Bart Vanbrabant 2005-05-19 19:38:39 UTC
Created attachment 559 [details]
Replace mmcache with eAccelerator

This patch replaces mmcache code with code for eAccelerator. Because mmcache
wasn't maintained anymore we further develop it in the eAccelerator project.
It's the code that's in mmcache cvs but with a lot of bugfixes at this moment.
Mmcache has some basic php5 patches in cvs but eAccelerator is almost fully
compatible with php5 (only the caching not yet encoding).
Comment 7 Brion Vibber 2005-05-20 10:08:08 UTC
Why is that patch posted on this bug? Not only is that a separate bug report, it's 
actually already been done.

Anyway, resolving as INVALID since the reported problem was caused by using an 
unsupported combination of versions.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links