Last modified: 2009-11-16 12:19:05 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18621 - Problem in edit with form
Problem in edit with form
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
SemanticForms (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Yaron Koren
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 10:51 UTC by Nahid
Modified: 2009-11-16 12:19 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nahid 2009-04-29 10:51:45 UTC
Hi Experts,
I don't know whether it is bug or I have missed something.
I was editing using 'Edit with form' but when my hook ('EditFilter' hook) reports some error in edit process it come back in 'Edit' mode not in 'Edit with form' mode.
Does any one have any idea about this problem?
Thanks
-Nahid
Comment 1 Yaron Koren 2009-04-29 16:36:16 UTC
Hi, what is this hook, and what's the error it reports?
Comment 2 Nahid 2009-04-29 20:00:26 UTC
Hi, 
Thanks for you attention, I have used this hook for my custom extension, here goes the reference link:
http://www.mediawiki.org/wiki/Manual:Hooks/EditFilter

If you set some $error, the page will not save and stay in edit mode. But as I told you before I want to stay 'Edit with form' mode because I start with this mode not in 'Edit' mode.

Thanks
-Nahid

(In reply to comment #1)
> Hi, what is this hook, and what's the error it reports?
> 

Comment 3 Nahid 2009-04-30 08:50:54 UTC
Take another simple scenario, there is a button 'Show preview' in edit mode.
If I press 'Show preview' in 'Edit with form' mode it gives us preview but returns to 'Edit' mode.
But I want to stay 'Edit with form' mode as I started with it.

Is there any solution of it?
-Nahid

(In reply to comment #1)
> Hi, what is this hook, and what's the error it reports?
> 

Comment 4 Yaron Koren 2009-04-30 17:56:43 UTC
I see - no, there's no solution for it, although a separate bug report here already requests that feature.
Comment 5 Yaron Koren 2009-11-01 05:05:29 UTC
This capability now exists in Semantic Forms, as of version 1.8.3; you just need to add the following to the top of the form definition:

<div id="wikiPreview" style="display: none; padding-bottom: 25px; margin-bottom: 25px; border-bottom: 1px solid #AAAAAA;"></div>
Comment 6 Nahid 2009-11-16 12:19:05 UTC
Its working !!! 
Thanks Yaron...

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links