Last modified: 2012-12-21 13:46:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18607 - Bold text that includes line breaks creates incorrect rendering
Bold text that includes line breaks creates incorrect rendering
Status: REOPENED
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.21.x
PC Windows XP
: Lowest enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: parser
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 17:36 UTC by Wolfgang
Modified: 2012-12-21 13:46 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
This text return in unexpected result (4.18 KB, image/png)
2009-04-27 17:41 UTC, Wolfgang
Details

Description Wolfgang 2009-04-27 17:36:56 UTC
When adding Text to the Edit-Area with '''Bold
Text''' including a Newline in the Textarea formats all the Text after the Linebreak to the end of that Line as bold.

Try the attached Text.
Comment 1 Roan Kattouw 2009-04-27 17:38:52 UTC
(In reply to comment #0)
> Try the attached Text.
> 

You didn't add an attachment.
Comment 2 Wolfgang 2009-04-27 17:41:03 UTC
Created attachment 6066 [details]
This text return in unexpected result
Comment 3 Roan Kattouw 2009-04-27 17:56:52 UTC
Confirmed this bug on testwiki. A simple testcase would be:

blah blah '''foo
bar''' buggy buggy

Instead of bolding "foo bar", this bolds "foo" and "buggy buggy".
Comment 4 Wolfgang 2009-04-27 18:00:55 UTC
With with [Newline
Links] it's a strange result too

Comment 5 Tim Starling 2009-06-23 03:58:27 UTC
This was discussed with Lee on wikitech-l years ago. He had some nonsense justification about line-based parsers being simpler or something. However, there was a more reasonable justification (possibly suggested by the same man) which is that ending bold and italic sections at newlines stops them from running on indefinitely and spoiling a large page. You can find many examples of this behaviour being used on Wikipedia talk pages, where people start italic sections accidentally. It's also possible that there are articles which would be broken by a change in this area.

I'll mark it LATER rather than WONTFIX since some day, in a few years' time, we might put syntax reform on the agenda. But any syntax changes will have to be carefully studied and widely announced. For now I'm mostly interested in consistency and backwards compatibility.
Comment 6 Andre Klapper 2012-12-21 13:46:25 UTC
Still valid in 1.21wmf6

[Removing RESOLVED LATER as discussed in http://lists.wikimedia.org/pipermail/wikitech-l/2012-November/064240.html . Reopening and setting priority to "Lowest". For future reference, please use either RESOLVED WONTFIX (for issues that will not be fixed), or simply set lowest priority. Thanks a lot!]

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links