Last modified: 2010-05-15 15:33:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1727 - Directory change for skins affected by rewrite rules.
Directory change for skins affected by rewrite rules.
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.4.x
Macintosh Mac OS X 10.3
: Normal blocker (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 14:47 UTC by Oscar van Vliet
Modified: 2010-05-15 15:33 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Special pages with broken rendering (8.10 KB, text/html)
2005-03-21 14:49 UTC, Oscar van Vliet
Details
screenshot of broken rendering (203.01 KB, application/pdf)
2005-03-21 16:49 UTC, Oscar van Vliet
Details
PHP info for more configuration details. (37.05 KB, text/html)
2005-03-21 16:50 UTC, Oscar van Vliet
Details

Description Oscar van Vliet 2005-03-21 14:47:14 UTC
I just upgraded to MediaWiki 1.4.0 from 1.3.x and found that all of my
formatting is lost. Opening page source showed that many " codes are now
rendered as '

These do not render and completely mess up all skins.

See this excerpt:

<div id='content'>
<div id='topbar'>
<table border='0' cellspacing='0' width='98%'>
<tr>
<td width='152' rowspan='1'>&nbsp;</td><td class="top" align='left' valign='top'>
<a href="/wiki/index.php/Main_Page" title="Main Page">Main Page</a>
Comment 1 Oscar van Vliet 2005-03-21 14:49:16 UTC
Created attachment 375 [details]
Special pages with broken rendering

Example
Comment 2 Oscar van Vliet 2005-03-21 14:51:17 UTC
I downloaded 1.4.0 at 11:40 CET from the Brussels mirror of Sourceforge.

Feel free to contact me privately to get rid of this bug.
Comment 3 JeLuF 2005-03-21 16:07:40 UTC
HTML specification allows usage of both " and ', see
http://www.w3.org/TR/html4/intro/sgmltut.html#h-3.2.2

Can you please tell us which browser you used? Exact version number and
operating system would be helpful, too.
What is rendered incorrectly, can you provide screenshots?
Comment 4 Oscar van Vliet 2005-03-21 16:48:27 UTC
I used Mozilla Seamonkey 1.8ß2 running on Mac OSX 1.3.8. I get the same results
with Safari 1.2.4 (v125.12).

I will attach a screenshot in a minute and an anonimized php.info.
Comment 5 Oscar van Vliet 2005-03-21 16:49:45 UTC
Created attachment 376 [details]
screenshot of broken rendering

Text renders, but the formatting is smashed.
Comment 6 Oscar van Vliet 2005-03-21 16:50:22 UTC
Created attachment 377 [details]
PHP info for more configuration details.
Comment 7 Oscar van Vliet 2005-03-21 16:52:42 UTC
The screenshot shows a classic skin with a floating left bar (well, it should).

Using monobook puts everything vertically in order, which makes it even harder
to find stuff..
Comment 8 Oscar van Vliet 2005-03-21 17:11:36 UTC
Updating summary

I also noticed there are slashes in the code where I do not expect them. I can
send .js files and .css files as needed, but I just unpacked the 1.4.0.tar.gz
archive and moved it to my server directory so nothing should have gone missing.
Comment 9 Rowan Collins [IMSoP] 2005-03-21 19:09:38 UTC
I couldn't immediately see what the problem was, but loading meta.wikimedia.org
in "Classic" skin, it looks to me like the CSS rules just aren't being loaded at
all. The most obvious error is the URL-expansions showing up on external links
(they should be hidden except for on print-outs).

Are the CSS files being loaded correctly? Are the paths to bits of the skin set
up correctly and accessible? I note that the logo in the top left has been not
found as well. 

Note that the location of these files has changed completely from 1.3 to 1.4, so
make sure you've:
1) put all the files in the right place
2) set any newly created files, such as these, to be readable/servable by the
webserver

Try loading the CSS files referenced in the source directly in your browser and
see what happens (and maybe watch the server log while you do it)
Comment 10 Oscar van Vliet 2005-03-21 19:54:45 UTC
OK, thanks everyone. I found it.

I put in some rewrites as per http://meta.wikimedia.org/wiki/Rewrite_rules

Those were still pointing at stylesheets, rather than skins. Oddly enough, I had
to restart and reload several times before the new skin came on line but it
works now.

Apologies for the fuss, and thanks again. An extra notice in the release notes
might be useful.
Comment 11 Rowan Collins [IMSoP] 2005-03-21 20:26:34 UTC
(In reply to comment #10)
> Oddly enough, I had to restart and reload several times before the new skin
came on line but it
> works now.

That's probably caching - combinations of pointing at
"...page_title?action=purge" and holding down Ctrl/Shift/similar while clicking
"refresh" usually deal with the various kinds of problem this creates (the
former being to bypass *internal* caches when the actual page rendering has
changed).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links