Last modified: 2009-12-24 12:02:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16965 - In-page links (e.g. [[#foo]]) currently register a NS_MAIN null-title missing entry in the link table
In-page links (e.g. [[#foo]]) currently register a NS_MAIN null-title missing...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.15.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/api.php?act...
:
: 16964 21841 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 02:21 UTC by Splarka
Modified: 2009-12-24 12:02 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Splarka 2009-01-11 02:21:26 UTC
<ref>anything</ref>   causes  <page ns="0" title="" missing="" />

See also bug 16964 - prop=links returns a title=""

This may not be a problem with this extension. If so, please change component to 'MediaWiki'.

There have been several linking irregularities, that may be related to this bug, or may have caused this bug while being fixed:

bug 16162 - namespace -1 and -2 links were possible
bug 16837 - escaped file links were not being registered
Comment 1 Brad Jorsch 2009-01-11 03:06:20 UTC
It has nothing to do with Cite in particular, it's just that MediaWiki:Cite_reference_link contains a link of the form [[#foo]]. That type of link is being parsed as a link to the page with title "" instead of being ignored (or parsed as a self-link).
Comment 2 Brad Jorsch 2009-01-11 03:13:42 UTC
Works in r45265, broken in r45266.
Comment 3 Alex Z. 2009-01-11 03:42:46 UTC
Fixed in r45656.
Comment 4 Alex Z. 2009-01-11 03:43:23 UTC
*** Bug 16964 has been marked as a duplicate of this bug. ***
Comment 5 Roan Kattouw 2009-12-24 12:02:01 UTC
*** Bug 21841 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links