Last modified: 2005-06-21 13:27:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1636 - failure in interlanguage links with leading zeros ( &+#+0+nnnn+; )
failure in interlanguage links with leading zeros ( &+#+0+nnnn+; )
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
PC Windows XP
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-05 10:27 UTC by lɛʁi לערי ריינהארט
Modified: 2005-06-21 13:27 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description lɛʁi לערי ריינהארט 2005-03-05 10:27:19 UTC
Dear friends,

the first interlanguage link in
http://en.wikipedia.org/w/index.php?title=Oltenita&oldid=10808167
will fail, the seccond will not.

ro:Olteniţa
ro:Olteniţa
are displayed properly in (my) browser (Mozilla Firefox)

It would be nice to fix this because it is just another "have to know".

The page is corrected. See:
http://en.wikipedia.org/w/index.php?title=Oltenita&diff=10808185&oldid=10808167


'''Note:''' The example of this behaviour relates to a [[Latin-1]] wiki. It is
not tested at [[UTF-8]] or right to left wikis.

Best regards
Reinhardt [[gangleri]]
Comment 1 lɛʁi לערי ריינהארט 2005-03-05 12:07:28 UTC
Halló! The bug has been reported at [[:sourceforge:projects/pywikipediabot]].

http://sourceforge.net/mailarchive/forum.php?thread_id=6739695&forum_id=36014

None of the hexadecimal variants ( +x as in &+#+x+0+nnnn+; ) has been tested so far.

Regards Reinhardt [[User:Gangleri]]

P.S. I wonder if pictures from [[commons:]] are available here
[[Image:Smiley.png|16px|;-)]]
Comment 2 lɛʁi לערי ריינהארט 2005-03-05 18:59:22 UTC
[[en:User:Gangleri/tests/bugzilla:1636]] shows olso other behaviors where links
are not generated at all, see :eo:ŝanĝo

(regarding comment #2)
The correct link is [[sourceforge:projects/pywikipediabot]] (if InterWiki's work
here else http://sourceforge.net/projects/pywikipediabot ).

Reinhardt
Comment 3 Christian Richardt [Richie] 2005-04-20 18:59:56 UTC
HTML entities are not correctly converted to characters.

> ro:Olteniţa links to [[:ro:Olteniţa]] with a "ţ" (lower case T with cedille)
> ro:Olteniţa links to [[:ro:Olteniía]] with an "í" (lower case I with accent aigu)

This "í" is actually #237 (decimal), which is #0355 (octal). I think, "0355" is incorrectly converted to an 
integer, leading zeros should be stripped.

By the way: Internet Explorer 6, Firefox 1.0 and Opera 8.0 display #355 and #0355 as the same character "ţ".
[[User:Richie]]
Comment 4 Brion Vibber 2005-04-21 06:33:06 UTC
wfMungeToUtf8() was incorrectly passing decimals in a way that got initial-zeroes interpreted as octal.

Fixed in CVS HEAD and REL1_4 and put live. Fix will be in 1.4.3.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links