Last modified: 2010-05-15 15:33:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1595 - Uploading file with category in description does not put file in category (templated or otherwise)
Uploading file with category in description does not put file in category (te...
Status: RESOLVED DUPLICATE of bug 73
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.4.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://creatures.wikicities.com/wiki/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-26 00:29 UTC by Laurence 'GreenReaper' Parry
Modified: 2010-05-15 15:33 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Laurence 'GreenReaper' Parry 2005-02-26 00:29:04 UTC
1. The description of a file when uploaded gets put as the file's page.
2. If you edit an uploaded file's page to put a category tag into it, then that
file is placed into the appropriate category. Similarly, if you put a template
that includes a category tag into a page then the page gets put into the category.

The above both work separately. However, it seems that the "should this page be
in a category?" checks are not run on the initial description provided when
uploading a file.

I want to use this template to avoid having to fill out any more details on a file:
Name: Template:Ingame image:
Content: [[Category:Ingame images]][[:Category:Ingame images|Ingame image]]: {{{1}}}
Use: {{ingame image|[[Creatures 3]] [[Rainbow Sharkling]]}}

If you upload a file with this template then if you look at the resulting page,
everything seems correct. However if you click the category link you find that
it is not present on the category page.

Placing the category separately in the description (without the template)
appears not to work either. I tried changing it to use this description:
[[Category:Ingame images]][[:Category:Ingame images|Ingame image]]: [[Creatures
3]] [[Rainbow Sharkling]]
and I got the same results as above - the file page is correct, but it only
places it into the category if you edit the page and save it (without making
changes).

Compounding the problem is that it '''looks''' like it has done it because the
category is displayed at the bottom of the file's page. The only way to see that
it has ''not'' gone into the category is to look at the category page itself.
Comment 1 Brion Vibber 2005-02-26 00:56:11 UTC

*** This bug has been marked as a duplicate of 73 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links