Last modified: 2008-10-08 19:33:09 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15882 - Multiple parameters makes CodeReview throw a backtrace
Multiple parameters makes CodeReview throw a backtrace
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CodeReview (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Aaron Schulz
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 16:17 UTC by Siebrand Mazeland
Modified: 2008-10-08 19:33 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Siebrand Mazeland 2008-10-07 16:17:20 UTC
Something like http://www.mediawiki.org/wiki/Special:Code/MediaWiki/status/resolved/author/siebrand makes CodeReview throw:

Internal error
From MediaWiki.org
Jump to: navigation, search

Invalid action specified

Backtrace:

#0 /usr/local/apache/common-local/php-1.5/includes/SpecialPage.php(537): SpecialCode->execute('MediaWiki/statu...')
#1 /usr/local/apache/common-local/php-1.5/includes/Wiki.php(225): SpecialPage::executePath(Object(Title))
#2 /usr/local/apache/common-local/php-1.5/includes/Wiki.php(55): MediaWiki->initializeSpecialCases(Object(Title), Object(OutputPage), Object(WebRequest))
#3 /usr/local/apache/common-local/php-1.5/index.php(93): MediaWiki->initialize(Object(Title), NULL, Object(OutputPage), Object(User), Object(WebRequest))
#4 /usr/local/apache/common-local/live-1.5/index.php(3): require('/usr/local/apac...')
#5 {main}

Is it meant to do that? I would love to be able to make the above work, though :)
Comment 1 Aaron Schulz 2008-10-08 19:06:56 UTC
An error is OK here. I'd say a *prettier* message could be used.
Comment 2 Aaron Schulz 2008-10-08 19:33:09 UTC
(In reply to comment #1)
> An error is OK here. I'd say a *prettier* message could be used.
> 

Done in r41849

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links