Last modified: 2008-09-06 19:29:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15471 - apprefix b0rken when searching for prefixes ending in a slash
apprefix b0rken when searching for prefixes ending in a slash
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
1.14.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Roan Kattouw
:
: 15500 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 11:21 UTC by Brad Jorsch
Modified: 2008-09-06 19:29 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brad Jorsch 2008-09-04 11:21:27 UTC
When using Special:PrefixIndex to search for subpages of a particular page, the recommended practice is to include a slash at the end of the query, e.g. [[Special:PrefixIndex/Main page/]]. However, this is currently b0rken in the API at least as of r40356: http://en.wikipedia.org/w/api.php?action=query&list=allpages&apprefix=Main-page/&aplimit=10 gives an error about "Main page/." being an invalid title.

This may have resulted from r40088; if so, changing the dummy character from '.' to 'x' should fix it. (OTOH, I could just be wrong about it).
Comment 1 Roan Kattouw 2008-09-04 13:42:50 UTC
(In reply to comment #0)
> This may have resulted from r40088; if so, changing the dummy character from
> '.' to 'x' should fix it. (OTOH, I could just be wrong about it).
> 

You're right about this. The choice for '.' was a stupid one anyway, as apprefix=Main_Page/. would behave very weirdly.

Fixed in r40432.
Comment 2 Brad Jorsch 2008-09-06 19:29:01 UTC
*** Bug 15500 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links