Last modified: 2009-12-30 05:13:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15420 - Internal server error when editing anonymously via the API
Internal server error when editing anonymously via the API
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
1.14.x
All All
: Normal critical (vote)
: ---
Assigned To: Roan Kattouw
http://pastebin.com/m11a11c12
:
: 15487 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 13:56 UTC by Dan Collins
Modified: 2009-12-30 05:13 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Collins 2008-09-01 13:56:07 UTC
When trying to edit via the API while logged out, I receive an internal server error. Attached are the queries and responses. Query 1 fetches the edit token, and completes successfully, query 2 tries to edit and fails, query 3 loads the page content and finds that it has not changed. Presumably, PHP crashes at some point while executing query 2.
Comment 1 Roan Kattouw 2008-09-01 18:03:39 UTC
I'll need some clues from the enwiki logs as to what caused the HTTP 500 before I can even start investigating this. Brion?
Comment 2 Dan Collins 2008-09-01 21:06:03 UTC
If it helps find the right logs, my IP is 24.0.66.109.
Comment 3 Roan Kattouw 2008-09-05 14:45:40 UTC
*** Bug 15487 has been marked as a duplicate of this bug. ***
Comment 4 Roan Kattouw 2008-09-05 15:10:02 UTC
Turned out to be a bug in ConfirmEdit. Should be fixed in r40493, please REOPEN
if you still get errors after r40493 has been synced.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links