Last modified: 2008-08-09 02:34:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15091 - Links to non-existent articles shouldn't have class "stub"
Links to non-existent articles shouldn't have class "stub"
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-09 00:50 UTC by PDD
Modified: 2008-08-09 02:34 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description PDD 2008-08-09 00:50:21 UTC
Since August 9, all links to non-existent articles ("red links") have not only the class "new" assigned but also the class "stub" (if stub detection is enabled in user prefs). This should be removed again, sincle it breaks the CSS styles many users have assigned to links of class stub. Non-existent articles are not stubs.
Comment 1 Fran Rogers 2008-08-09 02:34:54 UTC
Recent changes to the Linker class seem to have caused this bug. Fixed in r38980. :)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links