Last modified: 2008-07-06 20:19:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14646 - problem of HTML rendering in RSS feed
problem of HTML rendering in RSS feed
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: feeds
  Show dependency treegraph
 
Reported: 2008-06-25 17:30 UTC by David Crochet
Modified: 2008-07-06 20:19 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Source of the RSS feed (181.43 KB, application/xml)
2008-06-25 17:30 UTC, David Crochet
Details
a capture with a bad rendreing (142.32 KB, image/png)
2008-06-25 17:31 UTC, David Crochet
Details
screen shot with a good rendering (179.48 KB, image/png)
2008-06-25 17:32 UTC, David Crochet
Details

Description David Crochet 2008-06-25 17:30:26 UTC
Created attachment 5016 [details]
Source of the RSS feed

I read the RSS feed with Akregartor V1.2.2 under opensuse 10.1 (Linux 2.6.16.54-0.2.5-bigsmp i686) and some link do not appear good.

The problem is always in the <description> tag

For exemple with the attached file (XML and capture8.png).
for the second <item> with User talk:Ladykosha for <title> the link for the template is good rendering

but in this exemple (XML and capture7.png) (next <item> with Template:Добро пожаловать <title> ) the rendreding is not good, because instead of having a link, we have the full html text. (Red box)

I hope that my explication is good.

This problem appear with rename, upload, deletion action.

But never when a bot (interwiki.py with pywikipediabot script ) add a wikilink in the summary , or a rollback action
Comment 1 David Crochet 2008-06-25 17:31:29 UTC
Created attachment 5017 [details]
a capture with a bad rendreing
Comment 2 David Crochet 2008-06-25 17:32:55 UTC
Created attachment 5018 [details]
screen shot with a good rendering
Comment 3 Brion Vibber 2008-07-06 20:19:54 UTC
Fixed in r37202

Log entry action text was being double-escaped by running HTML through the comment parser.
Log action text is now output as straight HTML.

The link for long diffs was also coming out wrong on English Wikipedia due to overloading of messages.
Switched from 'differenes' (which is a label text which had gotten turned into an HTML link there) to 'showdiff', which is a plaintext button label. (Might consider making it a separate message which is a little more descriptive.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links